Pfsense on Alix 2d18



  • Hi all,

    This my first post so pls bear with me. I spent the entire afternoon yesterday and this morning reading/searching for the solution and found something similar but I still can not get mine working.

    I have a 4Gb compact flash card that I am hoping to use to install the PFsense image. I downloaded both the 4G and 2G versions of the -nanobsd.img.gz fle and tried to write them to the CF using physdiskwrite. In both cases I got an error stating that the disk is greater than 2 Gb..etc. I read somewhre how to overcome this problem but somehow I can't find it. I am using my notebook with WinXP with a CF reader/writer to do this.

    How can I make the 4Gb CF look as if it is 2Gb to WinXP? Pls advise.



  • From the m0n0wall install guide: (I think the limit changed from 800mb to 2GB at some point)
    Windows:
    (use the -u flag if the target disk is > 800 MB - make very sure you've selected the right disk!!)
    physdiskwrite [-u] generic-pc-xxx.img
    (you must use v0.3 or later!)



  • Thanks for the response. That did it. I am writing the 4Gb version at this time. It taking a bit long though. I just have to wait and see. Maybe I should have tried the 2Gb version.



  • Use dd for windows

    http://www.chrysocome.net/dd



  • The 4Gb was completed with errors. I then tried the 2Gb version on the 4Gb compact flash, and that completed satisfactorily. I now have my first PFsense box!!

    Is there any way to do remote administration on the system? That's what I am searching on now. Thaks for your support.



  • You can enable ssh under advanced or create a rule allowing https management from the WAN. Search around for more details.



  • @cenriq:

    Is there any way to do remote administration on the system? That's what I am searching on now. Thaks for your support.

    As dotdash stated, enable SSH and HTTPS under Settings->Advanced in the menus.

    What he didn't mentioned was that you MUST add firewall rules on WAN tab to allow incoming connections on these ports.  To reduce SSH brute force attacks, you might want to change the default SSH port from '22' to say..  '222'.

    If you do not want to reveal HTTPS on your WAN, you can always do a SSH tunnel socks proxy on the client then access the HTTPS webgui via the LAN IP.


Log in to reply