ROOT MOUNT ERROR: 1GB NanoBSD USB Drv [UN-Solved]



  • Guys, Wonder if you can give me any quick pointers.
    Hard to flip between dead router and forum as stuck in the old catch 22.
    Been using 1.2.3 on a Microdrive for years with no issues. Today I thought I'd try the 1Gb NanoBSD image of v2-RC but get the attached error.
    Have used embedded 1.2.3 on the same pen in the same slot before but wanted to go back to embedded NanoBSD as upgrades on the MicroDrive require me to mess about with the /boot/loader.conf every time which is a pain.

    Any quick pointers?
    pfsense.txt



  • @cheesyboofs:

    Have used embedded 1.2.3 on the same pen in the same slot before but wanted to go back to embedded NanoBSD as upgrades on the MicroDrive require me to mess about with the /boot/loader.conf every time which is a pain.

    Why aren't you using /boot/loader.conf.local instead of /boot/loader.conf?



  • Use Option 3 while booting from USB.

    http://doc.pfsense.org/index.php/Boot_Troubleshooting



  • @ wallabybob;
    As an advocate of pfSense I have been using it for some years. I have been running 1.2.x from a MicroDrive for the last couple of years but have to make the following alterations every time I upgrade,

    Anyway, found out that the /boot/loader.conf on the CD isn't the one that gets copied to the hard drive during install, the one on the CD has the line hw.ata.ata_dma=0 which is why the drive behaves during install but not on the reboot.
    
    So, I now have my microdrives working and this is what you may need to do,
    
    Boot the 1.2.x install CD - Under FreeBSD 7 my USB DVD-ROM now works yey, it didn't under 6.2
    Set LAN IP
    Do a fresh full install (99) to your microdrive as if it where a real hard drive.
    REBOOT (remove CD)
    
    (Microdrives don't like running at anything above PIO4 so in your PC BIOS Disable UDMA for IDE devices)
    If you don't do this you may not even be able to boot or you will get the spinnig cursor but it will spin REALLY slowly.
    
    Hit the space-bar when the kernel is loading (not at the Default F1 prompt) a little after, you should get an OK prompt.
    Then type;
    
    OK set hw.ata.ata_dma=0
    OK boot
    
    It should then boot all the way up to the pfsense menu.
    
    Drop to the shell by pressing 8
    
    Now edit /boot/loader.conf using vi;
    
    vi /boot/loader.conf
    
    Press the 'i' key and then move the cursor to the end of the last line and hit the enter key,
    add the line;
    hw.ata.ata_dma=0
    
    so it looks like;
    
    autoboot_delay="1"
    kern.ipc.nmbclusters="0"
    hw.ata.ata_dma=0
    
    then press Esc flowed by :wq
    
    Then press 'Ctrl D' to get back to the menu. Now you can restore your config by going to the web interface and quitting the wizard by clicking on the pfSense logo a couple of times.
    
    And the following reboot should boot fine without any kernel flags as you have already set them. If you restore your config before you have edited /boot/loader.conf you for some reason, on the subsequent reboots, can't input kernel flags and your install will be dead as you are now stuck in some weird catch 22.
    
    Here's a way around it:
    Go to a shell and:
    Code:
    touch /tmp/no_upgrade_reboot_required
    
    Run a firmware update as you normally would, then it won't reboot at the end.
    
    Go back to a shell and then redo your loader.conf changes.
    

    As you can imagine this is somewhat a pain as I understood it at the time these changes to /boot/loader.conf did not survive an upgrade and the following reboot would fail. I was not aware of /boot/loader.conf.local I'm sure it wasn't there then.

    @ onhel;

    All I see is what you see in the screen dump provided, (serial connection only)

    1  pfSense
    2  pfSense

    No option 3, but I will try as you suggest entering "set kern.cam.boot_delay=10000" at the "Hit [Enter] to boot immediately, or any other key for command prompt."

    As I have had to go through such a palaver every time I upgrade I had hoped that I would not have to if I went back to embedded as when I used to run 1.2.x embedded on the same hardware  I never witnessed the issue I have now.

    Thank you both of you for taking the time to respond.



  • Entering "set kern.cam.boot_delay=10000" at the "Hit [Enter] to boot immediately, or any other key for command prompt."

    Seems to have solved the problem - many thanks.



  • Guys can you tell me how to make this setting (kern.cam.boot_delay=10000) survive an upgrade?

    I've tried adding it to both  /boot/loader.conf.local and /boot/loader.conf but every time I upgrade the router fails to boot and I have to gain local access again just to issue the command.
    I don't know why it cant be part of the default config as it only ads a fraction of a delay to the boot but would help us working with USB immensely…

    Cheers


Locked