USB keyboard problem during install



  • I'm trying to install pfSense 1.2.3 on a Dell Optiplex 210, which has 6 onboard usb ports, but no ps2 ports.  I boot from disk and am able to use the keyboard to select the boot options, but partially through the boot menu I see a message:

    usb0: host controller halted
    uhub2: device problem (IOERROR) disabling port 1

    When prompted to configure vlans the keyboard in inoperable.

    I attempted to follow the steps here http://doc.pfsense.org/index.php/Booting_Options#Using_a_USB_keyboard but there was no change (the keyboard worked fine while setting the variable).

    Has anyone seen this before and have a workaround?

    Thanks



  • Try whats outlined on this topic, and see if that works for you.
    http://forum.pfsense.org/index.php/topic,2452.0.html



  • Yep, that's my problem.  I went down to my local hardware store and picked up a PCI USB card, which allowed me to install pfSense.

    I'm left with an interesting setup which I must use the onboard USB ports if I want to configure the BIOS, or the PCI ports if I want to configure pfSense.  As far as the solution goes I'm satisfied, but is there any plan to allow for a boot parameter to disable EHCI?



  • Have you tried a pfSense 2.0 snapshot build? Sometime newer software works better with newer hardware. A while back I had trouble usb USB devices on a motherboard with AMD 780G chipset and snpshot builds of pfSense 1.2.3. A few months later the problem didn't happen with the released version of 1.2.3.


Log in to reply