Client -> Squid ->SquidGuard -> Havp/Antivirus -> Privoxy -> Internet



  • Please help.. I know I am trying an unsupported configuration but hopefully other users can help me.

    I am running up to date pfSense 2.0 RC as of April 4, 2011 and am having trouble getting Privoxy working on my box in the chain. I installed privoxy from freebsd ports.

    Currently I am at this state. The following works:
    Client -> Squid -> SquidGuard -> Havp/Antivirus -> Internet

    and the following also works and is installed on the same box:
    Client -> Privoxy -> Internet

    But if I try to configure the Havp proxy to use a parent proxy (Privoxy), my clients all get the error message from Havp… "The following server is down. Could not read headers"

    I have tried configuring privoxy to listen on actual interface address and port 8008 and then set Havp parent as interface address:8008 and got the above problem. Then I also tried it configuring Privoxy as localhost:8008 and then setting Havp parent to localhost:8008 and got the same error.

    If I set Privoxy as interface address and 8008 then point clients to that port directly it forwards through to the internet.

    Please help.



  • I don't know if this helps, but you could put Privoxy on the clients and have Squid/SquidGuard/HAVP running under pfSense.

    Client (w/ Privoxy) –>  pfsense (w/ Squid/SquidGuard/HAVP) --> Interweb-Thingy!

    Both my Hackintosh and my Ubuntu Linux boxes are setup like this with no problems.  The only problem is the "administration" of Privoxy, OK for one or two clients, but for more than a dozen, then it could become a PITA.

    :)



  • Hi Getut,

    I am trying to get Client -> Squid -> SquidGuard -> Havp/Antivirus -> Internet to work but I am kind of confuse how to get it to work. Could you let me know how you did it?

    Thanks in advance,

    pat



  • Its really easy:

    Install squid, at general settings set "proxy port" to 3125. Squid is set as transparent proxy.
    Install squidguard and configure it.
    Now install havp and configure it as "parent for squid", "proxy port" set to 3125.

    Thats the short story, should work.

    Try first only squid - squidguard to get that working, then after success install/configure havp.

    with privoxy i can't help. sorry


Log in to reply