Intel PCMCIA



  • I'm thinking about getting a couple of INTEL 10/100 MOBILE ETHERNET PC CARD 32BIT PCMCIA WITH DONGLE KIT Part# MBLA3200, to install it on a laptop running pfSense 1.2.3. Any issues with using the Intel PCMCIA network cards with ver 1.2.3 or ver 2.0 ?

    I need to be able to use traffic shaping, so I'm trying to stick to Intel nic's.

    Any help is highly appreciated !

    TJ



  • PCMCIA bus is quite slow and the two slots share the same bus.  Please take a look at this http://www.quatech.com/support/comm-over-pcmcia.php



  • Thank you Seth for that very informative article, now I know.

    Do you or anybody else know of any issues with this mini-itx box for pfsense with an Intel 3 Port LAN Daughter Board ?

    http://www.mitxpc.com/proddetail.asp?prod=EKJA330M350P80&cat=59

    TJ



  • Many people are using that board with that daughtercard.

    I've got 3 of them out there. All work fine. Search the forums, there's many references.



  • Thanks for the info mrboston.

    I searched the forums and came across older threads that users said they had some minor problem with it. Since these were from year 2008 or 2009 and nothing newer I wanted to make sure that this board worked.

    Per pfsense's definitive guide, I'm sticking to Intel Nic's. The daughter card I'm planning on getting is an Intel 82541PI AD3INLANG, can any body confirm that this card will support traffic shaping?

    TJ



  • Intel 82541PI is under the HCL. Is is safe to assume that this card will do traffic shaping ?

    TJ



  • Here is the info from another thread;
    –---------------------------------------------------
    The following interface types are ALTQ compatible:

    "an", "ath", "awi", "bfe", "bge", "dc", "de", "ed",
    "em", "fxp", "hme", "lnc", "ndis", "rl", "sf", "sis", "sk",
    "tun", "vr", "wi", "xl", "vlan", "ste"

    HCL reports the below;
    The em(4) driver supports Gigabit Ethernet adapters based on the Intel 82540, 82541ER, 82541PI

    So is it safe to assume that the Intel daughter card I'm planning on buying will support traffic shaping?

    TJ



  • ok, I need to start a new topic and not jump in over the pcmcia topic.

    TJ



  • My mbla3200 cards do not work with pfsense past 1.2.3.

    You can google Xircom 3201 (which i believe is the controller for these cards) and will see my threads on this issue.  Evidently freebsd stopped supporting them at some point, and I have never been able to get them to work on 2.0.  Tried with the latest RC and it was the same thing.  Found this thread looking to see if its fixed.


Log in to reply