Looking for that lost 3.5Mbps?



  • Update
    Before reading this….plz plz plz....check the hardware compatability listing on the pfsense website. You will save yourself a lot of trouble and heartache :-))

    Hi,
    I hope someone can help. I've searched the forums, read the book and googled quite a bit today but can't seem to find what I am doing wrong.

    Trying to configure the latest build of 2.0 on a P4, 2.8Ghz with 1.5g of ram. It's complete overkill for what I need this machine for but it's the only spare bit of hardware I have. It's an extremely basic setup. The idea was to start with a very basic setup, get to know the system and start tweaking later down the line when I'm more comfortable with the components.
    So at the moment, I have my adsl +2 modem bridged to the WAN interface and a pc plugged into the LAN. Very few packages installed (Iperf and the OpenVPN windows client installer package).

    Rules-wise,
    lan-to-lan (allow all).
    Lan->Wan (allow all)

    I'm getting internet connectivity. On speedtest.net I'm averaging about 3.5Mbps but my service is 8Mbps and before pfsense I was getting a steady 7Mbps.

    The box that it's installed on is under no pressure. Max memory usage is about 11%.
    I've had a look in the system logs and nothing seems to be jumping out at me but I am a noob so of course it may well be staring right out at me :)

    The 'only' thing I can think off that might make a difference is the LAN nic I used is a generic 'sundance' (I think!). It was a cheapo 100Mbs but has functioned well beforehand.

    Just wondering if anyone else has come across a similar problem? Any help or advice would be gratefully received. My head is a little bit wrecked.

    Thanks Guys,
    Kind Regards,
    Niall



  • Yeah the nic can make a big difference as I found testing some old PCI cards I had laying around. But did you set the MTU?  I dropped mine lower than the PPPoE default of 1492 to 1444 & it seems to fly leaving some room to spare. Btw, I assume you didn't run traffic shaper & put too low of value by chance.. :D
    Bill



  • Hi Bill,
    Thanks for coming back to me. I had the ISP default MTU in. This morning I played around with various values but the most it increased the download bandwidth was to 4Mbps. I also tried a different modem (again in bridge mode) and was getting the same results. Going to see if I can find a good secondhand NIC on ebay and try it with that.
    Will report back.
    Rgds,
    Niall



  • Try doing PPPoE with pfSense instead of having the modem do it, sometimes I've seen this increase performance, as Bill48105 said it could be due to the nic but I doubt it would drop speeds that low.



  • Thanks NiteSnow.
    I was trying it with the WAN as PPPOE. The problem is that different router/modems have different interfaces and a lot of choices when it comes to Bridge mode. Interestingly enough, I have a pretty crappy Zyxel 660HW-T1 here at home. While all of the the speed 'issues' were going on, I did manage to get into a bridged mode (I think!). There were quite a few options. I will try to remember the values I put in. Wrong configuration of the modem/router could of course have a huge impact on speed.
    So here's how I had it setup.

    I connected a bog standard cat5 cable from port 4 on the dsl modem to the WAN interface. At the same time I had a cat5 cable from my Win XP machine to the LAN interface.

    On the DSL modem I went to the WAN section.

    1. I left 'modulation' as: multi mode.
    The other options were ADSL G.dmt, ADSL2, ADSL2+, ADSL2 AnnexM, ADSL2+ AnnexM, READSL2 Mode, ADSL G.lite. I have just noticed on the main summary page of the modem/router that ADSL G.dmt is used but the girl in the ISP told me to keep the multi mode setting as stated above.

    2. Under 'General', I switched from 'routing' to 'bridge'

    3. Encapsulation, I chose 'RFC 1483'.
    The other option was PPPoA but I know the ISPs here in Ireland in the main use PPPoE.

    4. Multiplexing, I left with the default LLC, VPI and VCI values.

    On the WAN settings within PFsense I put in the ISP PPPoE settings, username and password. It took some time for the WAN interface to come up but when it did it appeared to be working ok just poor speed.

    So, a little following on to the above. (which I started writing).

    After almost giving up on the speed problem, I decided to put the modem/router back into routing mode (non-bridge). I then to my surprise saw that the downstream the modem was receiving was 4Mbps!! I tried the other modem/router I had, same result. I got onto the ISP helpdesk. They couldn't explain what had happened. They said that they would lower the 'profile' (whatever that means) to match the downstream and sometimes then the downstream will improve. So it did, the profile was lowered to match the 4Mbps downstream. Then they reset it again and the downstream went back up to 7.1Mbps but alas, not the 8.1Mbps that I was getting before all of this.

    Unfortunately, I cannot test it again as the firewall is now out on location. I spent most of the day trying to get it up and running but the WAN would not come up. It's a different ISP but the same modem. It might be that I didn't have the right password for the DSL account, by the time I went to check they had closed for the evening.

    One question I do have is, did I set the modem/router to the correct 'bridge' settings? And if so, does it matter what port I use to connect the WAN to on the modem/router? Is there any other setting that I potentially missed or would you have done anything different?
    Should I have used a crossover cable maybe?

    Thanks once again for any help or advice.

    Kind Regards,
    Niall



  • Hi Guys,
    Just back in the door after a long long day.

    Well it's all up and running and have learned a precious lesson.

    After many phonecalls with the ISP and digging about on forums I got up, walked away from the desk and got some fresh air. I decided to go back to basics.

    First up, check the cat5 cabling. Whilst checking it, (by pinging the LAN and WAN interfaces) with a direct connection to my laptop, I found I couldn't ping the WAN interface. I thought, gotcha!! There must be a problem with the cable. Swapped it out, same with the replacement cable. Then I started looking at the WAN NIC. This was a Broadcom NetXtreme Gigabit integrated with the motherboard. Remember, I thought I had got it working the previous day so it must be compatible. Went to the Free BSD compatability hardware list. It had lots of Broadcom NetXtreme cards all in the Broadcom NetXtreme II family but not the original. I was gutted. I was sure I had checked it beforehand and remember I was more concerned about the Sundance (ST201) card, that is supported. So in the end I didn't use the motherboard NIC but put in another Sundance (ST201) card and hey presto!! All up and running and no speed degradation.

    I feel frustrated, tired and more than a little bit stupid….grrr!!

    Anyone else reading this post....check the hardware compatibility list. Save yourself some blood sweat and tears ;-)

    Have ammended the original posting accordingly.

    Thanks for the help anyway guys.

    Kind Regards,
    Niall


Log in to reply