Ntp/Daylight savings problem



  • Hi!
    I've just setup a pfsense box in the office, thanks for a great product (and the book also, which was a great help!). However, ntp is setting the wrong time, possibly due to DST shift? The office is situated in Stockholm, Sweden, and I've set my ntp-servers to [0-3].se.pool.ntp.org, and time zone to Europe/Stockholm, but time is off by +2 hours.

    Any ideas? Also, is there any better way to check current time than Diagnostics > Command prompt > date? Seems to me it should be visible on the system status page, for instance…


  • Rebel Alliance Developer Netgate

    Have you rebooted since you set the time zone? Many processes will only pick up a time zone change when they are restarted.



  • Yep, rebooted to no effect. It seems to be double compensating somehow - if I set time zone to GMT and use [0-3].pool.ntp.org (not .se.) I get correct time…


  • Rebel Alliance Developer Netgate

    Seems odd that it would miscalculate it with the named time zones, usually the GMT+/- number zones have issues but not the geographically named ones.

    What happens if you use the normal pool.ntp.org servers and the Europe/Stockholm time zone?



  • Just tried it, clock instantly jumps forward 2 hours… Other way round (se-ntp servers, GMT time zone) gives expected time.



  • Interesting thing, I'm looking through my logs, and log entries are not continous in time, for instance (reverse log view enabled, so latest event first):

    
    Apr 7 13:11:54 check_reload_status: reloading filter 
    Apr 7 11:11:01 kernel: em1: promiscuous mode disabled 
    Apr 7 11:09:43 kernel: em1: promiscuous mode enabled 
    Apr 7 12:39:08 check_reload_status: reloading filter 
    Apr 7 10:31:14 syslogd: kernel boot file is /boot/kernel/kernel 
    Apr 7 12:31:14 syslogd: exiting on signal 15 
    Apr 7 12:17:54 kernel: vlan2: promiscuous mode disabled 
    Apr 7 12:17:54 kernel: em1: promiscuous mode disabled 
    Apr 7 12:16:52 kernel: vlan2: promiscuous mode enabled 
    Apr 7 12:16:52 kernel: em1: promiscuous mode enabled 
    Apr 7 12:01:11 check_reload_status: reloading filter 
    Apr 7 10:01:11 php: : Processing - 
    Apr 7 10:01:11 php: : Processing start - 
    
    

    I did not change system time or mess with ntp during this time. Do different components use different time sources? Or do some of them try to correct for time zone themselves?


  • Rebel Alliance Developer Netgate

    That's typical of switching a time zone and then not rebooting/restarting a process. Processes only pick up a new time zone when (re)started.


Log in to reply