Interface stops passing traffic



  • 2.0-RC1 (amd64)
    built on Sat Mar 26 00:18:39 EDT 2011

    This box has two physical interfaces, both using vlans on all their networks. Both are on-board Intel GBE using the em driver. After more than 6 days of uptime one of these interfaces stopped functioning altogether. On the vga console all the interfaces still had their IP information, but from the shell I could not ping any host on any attached vlan (network unreachable), nor could any of the hosts I tried from get a response from pfsense. I tried "ifconfig em1 down" and "ifconfig em1 up" but this changed nothing. dmesg showed no clues as to the cause.

    The other physical interface (pppoe and modems) appeared to be functioning normally.

    I rebooted pfsense and all appears to be functioning as expected for the past two hours.

    Any idea what to look for now or when it happens next?



  • From the description it seems like a bug that was fixed in em(4) driver just lately.
    Upgrade to the latest snapshot that has the fixes in and test with it.


Log in to reply