(solved) CARP: no switchback to master



  • {amd64}
    I have two identical servers and have setup CARP all the interfaces. When CARP switches to the slave (for whatever reason) it doesn't switch back to the master when possible. If this is as designed, I propose to have a selection of the desired action.

    Why I want this:
    When em0 is active on master and em1 is active on slave then traffic between those networks is very slow (but this may be another wrong setting). When they both are active on the same server speed is good.



  • So I found, used and tested the "Base" setting in the virtual IP settings and it does what I want.



  • The problem persists because the base on the slave is reset back to 1 when the VIP or other (don't know which exactly yet) settings are edited.



  • So you want a different setting of base between master and slave?
    What is the reason and why it would help you?



  • Problem solved.

    The problem was that I had setup a CARP IP for a future network but I had no switch yet so the network cards were not connected. As soon as both cards were connected to the switch CARP started working perfectly.


Locked