Single Wan Multi LAN DHCP-server Problem (SOLVED)



  • After I upgraded to 2.0 RC1 i've started to have dhcp server problems a lot.

    Before upgrading everything worked well (1.2.3). I even changed harddrive and reinstalled 2.0RC1 from to ground up.
    Firmware is up to date.

    Is there anything what i can do? Other than to manually configure static ip's to clients

    For saving time: I had faulty ip-addressing scheme for openvpn networks, and by removing that dhcpd booted up..



  • You're not telling what problems you have…...



  • Yes indeed sorry.

    The problem is that dhcp servers doesn't work.
    Interfaces is configured as static, DHCP-server is enabled but not even one client have IP-addresses from firewall.



  • Do you have a firewall rule to allow DHCP traffic?
    Only a rule to allow the "interface_subnet" is not enough.
    Afaik there was once a version which didn't require such a rule.

    Sorry was thinking of DHCP and bridges here….



  • Thank you for the answer but it still doesn't work

    no matter if set that rule really specific or simple(kiss is good guideline)



  • On interfaces where the DHCP server is enabled, the rules to allow DHCP requests are automatically added. Not enough info here to tell what's happening, DHCP logs, system logs, status of dhcpd under Status>Services, may be helpful.



  • @cmb:

    On interfaces where the DHCP server is enabled, the rules to allow DHCP requests are automatically added.

    I presume "rules" means "firewall rules". This must be a relatively new feature. In my system running 2.0-RC1-IPv6 (i386)
    built on Wed Apr 6 23:30:13 EDT 2011
    I have DHCP enabled on LAN (bridge0) and I can't see any "automatic" rules to allow DHCP. A while ago (maybe a couple of months) I had to add firewall rules to each of the bridge member interfaces to allow from 0.0.0.0 to 255.255.255.255 for DHCP to work. Those rules are visible.



  • Thank you to all

    I had faulty setup concerning openvpn interface. And that why dhcpd was shut all the time and refused to start itself or by manually.
    After i corrected setup then dhcp was started by itself.

    @cmb: thank you i didn't know the location for the dhcpd or other services
    @wallabybob & GruensFroeschli: I put that rule for optional networks, thank you for your advice.


Log in to reply