Creating dev-iso strange error



  • I tried to create a dev-iso, but it fails!

    /build_iso.sh 
    >>> Using /home/pfsense/tools/builder_scripts/remove.list.iso.8 ...
    >>> Updating system clock...
     8 Apr 08:34:42 ntpdate[1222]: adjust time server 188.193.213.135 offset 0.007917 sec
    >>> Operation ./build_iso.sh has started at Fri Apr  8 08:34:42 CEST 2011
    >>> Grub is not buildable on AMD64.  Skipping.
    >>> Cleaning build directories: Done!
    
                     Remove list: /home/pfsense/tools/builder_scripts/remove.list.iso.8
                       Copy list: /home/pfsense/tools/builder_scripts/../builder_scripts/copy.list.RELENG_8_0
                MAKEOBJDIRPREFIX: /usr/obj.pfSense
               pfSense build dir: /usr/pfSensesrc/src
                 pfSense version: 2.0-RC1
                        CVS User: sullrich
                       Verbosity: 
                        Base dir: /home/pfsense/tools/builder_scripts/../..
                    Checkout dir: /home/pfsense/tools/builder_scripts/../../pfSense
                     Custom root: /home/pfsense/tools/builder_scripts/../../pfSense
                  CVS IP address: cvs.pfsense.org
                     Updates dir: /tmp/builder//updates
                    pfS Base dir: /usr/local/pfsense-fs
                   FreeSBIE path: /home/pfsense/tools/builder_scripts/../../freesbie2
                   FreeSBIE conf: /dev/null
                      Source DIR: /usr/pfSensesrc/src
                       Clone DIR: /usr/local/pfsense-clone
                  Custom overlay: 
                 pfSense version: 8
                  FreeBSD branch: RELENG_8_1
                     pfSense Tag: HEAD
                           EXTRA: customroot
                           EXTRA: customscripts
                           EXTRA: pkginstall
                           EXTRA: buildmodules
                           EXTRA: rootmfs
                           EXTRA: varmfs
                           EXTRA: etcmfs
                MODULES_OVERRIDE: i2c
                MODULES_OVERRIDE: ipmi
                MODULES_OVERRIDE: acpi
                MODULES_OVERRIDE: ndis
                MODULES_OVERRIDE: ipfw
                MODULES_OVERRIDE: ipdivert
                MODULES_OVERRIDE: dummynet
                MODULES_OVERRIDE: fdescfs
                MODULES_OVERRIDE: cpufreq
                MODULES_OVERRIDE: opensolaris
                MODULES_OVERRIDE: zfs
                MODULES_OVERRIDE: glxsb
                MODULES_OVERRIDE: runfw
                MODULES_OVERRIDE: if_stf
                  Git Repository: http://gitweb.pfsense.org/pfsense/mainline.git
                      Git Branch: 
                   Custom Config: 
                         ISOPATH: /tmp/builder//pfSense.iso
                         IMGPATH: /tmp/builder//pfSense.img
                    MEMSTICKPATH: /tmp/builder//pfSense-memstick.img
                      KERNELCONF: 
            TARGET_ARCH_CONF_DIR: /usr/pfSensesrc/src/sys/i386/conf/
         FREESBIE_COMPLETED_MAIL: 
             FREESBIE_ERROR_MAIL: 
                        SRC_CONF: /home/pfsense/tools/builder_scripts/conf/src.conf.8
    CROSS_COMPILE_PORTS_BINARIES: 
                SPLIT_ARCH_BUILD: 
        UPDATES_TARBALL_FILENAME: /tmp/builder//updates/pfSense-Full-Update-2.0-RC1-amd64-20110408-0834.tgz
    
    >>> Fetching BSDInstaller using CVSUP...
    >>> Updating BSDInstaller collection...Done!
    >>> Creating installer tarballs...Done!
    >>> Copying ports to the ports directory...Done!
    >>> Rebuilding BSDInstaller...Done!
    >>> Setting CVSUp host to cvsup2.freebsd.org
    >>> Removing needed files listed in patches.RELENG_8_1 HEAD
    >>> Obtaining FreeBSD sources RELENG_8_1-supfile...Done!
    >>> Removing old patch rejects...
    >>> Applying patches from /home/pfsense/tools/builder_scripts/../builder_scripts/patches.RELENG_8_1 please wait...Done!
    >>> Finding patch rejects...
    >>> Updating pfSense GIT repo...
    >>> Cloning http://gitweb.pfsense.org/pfsense/mainline.git / HEAD...Done!
    >>> Using GIT to checkout HEAD
    >>> Checking out tag master...Done!
    >>> Making sure we are in the right branch... [OK] (master)
    >>> Creating tarball of checked out contents...Done!
    >>> Preparing object directory...
    >>> Building world and kernels for ISO... 8  RELENG_8_1 ...
    >>> Building world for amd64 architecture...
    >>> World build started on Fri Apr  8 09:01:02 CEST 2011
    >>> Rebuilding the temporary build tree
    >>> stage 1.1: legacy release compatibility shims
    >>> stage 1.2: bootstrap tools
    >>> stage 2.2: rebuilding the object tree
    >>> stage 2.3: build tools
    >>> stage 3: cross tools
    >>> stage 4.1: building includes
    >>> stage 4.2: building libraries
    >>> stage 4.3: make dependencies
    >>> stage 4.4: building everything
    >>> stage 5.1: building 32 bit shim libraries
    >>> World build completed on Fri Apr  8 09:39:18 CEST 2011
    >>> Ensuring that the btxld problem does not happen on subsequent runs...
    >>> Installing world for amd64 architecture...
    >>> Making hierarchy
    >>> Installing everything
    >>> Building all extra kernels... 8  RELENG_8_1 ...
    >>> Building uniprocessor kernel...
    >>> Not adding D-Trace to Kernel...
    >>> KERNCONFDIR: /usr/pfSensesrc/src/sys/i386/conf
    >>> ARCH:        amd64
    >>> SRC_CONF:    src.conf.8
    >>> Kernel build for pfSense.8 started on Fri Apr  8 09:40:41 CEST 2011
    >>> stage 1: configuring the kernel
    >>> stage 2.2: rebuilding the object tree
    >>> stage 2.3: build tools
    >>> stage 3.1: making dependencies
    >>> stage 3.2: building everything
    >>> Kernel build for pfSense.8 completed on Fri Apr  8 09:47:34 CEST 2011
    >>> Installing uniprocessor kernel...
    >>> Installing kernel
    >>> Executing cd /tmp/kernels/uniprocessor/boot/kernel
    >>> Building embedded kernel...
    >>> Phase install_custom_packages
    >>> Mounting devfs /usr/local/pfsense-fs/dev ...
    >>> Phase set_image_as_cdrom
    >>> Searching for packages...
    >>> Installing packages listed in /tmp/pfspackages
    >>> Finding origins... 1 found
    >>> Finding dependencies... 2 found
    >>> Sorting 3 packages by dependencies... done.
    >>> Copying 3 packages
    [0...]
    >>> Installing packages: 
    >>> Installing packages: 
    bsdinstaller-2.0.2011.0408
    >>> Using FreeBSD 8 BSDInstaller dfuibelua structure.
    cp: /usr/local/pfsense-fs/usr/local/bin/after_installation_routines.sh: No such file or directory
    
    

    looking for that error results in that:

    %ls /usr/local/pfsense-fs/usr/local/
    share

    The bin-folder is missing, and i think, others too. What can i do to get rsults? Tried several times to create the iso, but it fails every time. :(

    edit: it was a disk full error. Hope that was all…


  • Rebel Alliance Developer Netgate

    I've setup several builders lately and they all work as expected. There may be something in your setup that isn't quite right. What do you have in your pfsense-build.conf ?



  • It was only the disk full. Creation of dev-iso worked fine finally. Thanks for your help!


Log in to reply