DHCP Across multiple interfaces



  • Alright I read few posts on this but didn't understand the resolution, so here is my scenario:

    I have a total of 5 interfaces:
    stge1 - WAN
    stge0 - Lan0
    re0 - LAN1
    re1 - LAN2
    re2 - LAN3

    stge0 was the first interface to be assigned via console.

    I have assigned and enabled the other interfaces and designated them the names as shown above.
    All interfaces have the default any to any rule.

    I have bridge0 configured with the following interfaces:
    stge0
    re0
    re1
    re2

    Issue is that DHCP is only operational on stge0 which was the first assigned during setup. But DHCP is not working on any other interface and DNS is also not being passed through either.
    I confirmed that by giving each node on the network a static IP and specify the DNS servers given by my ISP they will connect and can pull up the pfsense webGUI and can look up the DNS for domains.

    I assume this is got something to do with the FireWall rules but I am not sure. Any advise is greatly appreciated



  • Alright I got DHCP going on all interfaces by following the advice on this thread http://forum.pfsense.org/index.php/topic,33878.0.html BUT DNS is still not being passed to clients on the network.



  • @ClayK47:

    BUT DNS is still not being passed to clients on the network.

    What DNS are you expecting to be passed to clients?



  • Just the ISP DNS, I was able to get a few any to any rules to resolves some sites but have now run into another issue where I am unable to download a single file from a site. Trying to do a Speed Test from multiple different providers fails to even connect. I can see the block in the FireWall log and have tried to add an any rule to allow downloads from any host, but it did not work, I am most likely structuring it wrong. I guess its worth to note that I was using 2.0 RC1 then just now reinstalled with the stable 1.2.3 but still got the same issue, might upgrade back to 2.0 RC1.

    But I guess at this point it just sounds like my issues are firewall issues…



  • Just wanted to say that it did come down to a hardware issue of some sorts. Not sure what is up with the PCI port for NIC I was using for the WAN interface but switch the interface assignment and I am able to view sites and download w/o issue. Thanks for the advice on the HW!


Log in to reply