OpenVPN, can't connect.

  • Hey Gang,

    Got it working once…

    Kept getting "No server certificate verification method has been enabled." Read trough the documentation and found it meant that the CA wasn't in my configuration file, added it, didn't help.

    Figured it might be that my CA file had a + in I complete tore down my OPENvpn setup, deleted all my certs, removed the rules and started from scratch.

    Built fine but now I can't connect to my server, I have checked my IP a dozen times, the rules are all there on the right port but it just wont acknowledge my connection.

    Anyone have any idea what I am missing?


  • Found my own answer, the export package somehow got "stuck"

    It was still packaging up the original cert instead of the newly build ones.

    Now if anyone has advice how to fix the "WARNING: No server certificate verification method has been enabled." problem, I have tried adding:
    ca server-ca.crt
    ns-cert-type server

    But I start getting:
    Wed Feb 09 11:44:45 2011 TLS_ERROR: BIO read tls_read_plaintext error: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed
    TLS Error: TLS object -> incoming plaintext read error
    TLS Error: TLS handshake failed
    Fatal TLS error (check_tls_errors_co), restarting
    SIGUSR1[soft,tls-error] received, process restarting

    Thanks all!

Log in to reply