Traffic Shaper, qVoIP on Wan staying empty? (solved)



  • Hi,

    i'm running 2.0 RC1 ( 2.0-RC1 (i386) built on Thu Apr 7) on an alix board and I've lately noticed that the "qVoIP on WAN" is staying empty on my phone calls/conversations.
    The floating rules were created using the wizard and the VoIP rule was adjusted to fit the source/destination as follows (see attachment). The rule was setup to "any" and with the "quick" option.

    192.168.2.252 = VoIP Adapter on LAN
    213.148.136.2 = ISP SIP Server

    During a conversation i monitored pftop and got:

    PR    D SRC                   DEST                 STATE   AGE   EXP  PKTS BYTES
    udp   I 192.168.2.252:5060    213.148.136.2:5060    2:2  7914m    60  275K   77M
    udp   O 192.168.2.252:5060    213.148.136.2:5060    2:2  2759m    60   97K   27M
    udp   I 192.168.2.252:16472   213.148.136.2:19524   2:2    348    60 28995 1812K
    udp   O 192.168.2.252:16472   213.148.136.2:19524   2:2    348    60 28995 1812K
    

    On the queues i can see "qVoIP on LAN" getting properly filled up but "qVoIP on WAN" staying empty.
    I triple checked all the rules by now, and its not an overriding problem. Does anyone have an idea or explanation?

    any help appreciated! :)



  • ok it looks like the data is getting into the "qP2P on WAN" queue which is also the default queue but i dont see why…

    [Edit]
    yes its definitely going into the qP2P on Wan queue, just left it to idle traffic and made an test call/conversation and it got filled the moment i accepted the call!

    is there any way i can trace the cause of this?



  • problem solved!

    i had to add some addition floating rules for voip on wan side ( see attachment)
    it works as expected now! wan traffic gets properly queued as does lan traffic! (lan did before too, i only renamed and add ports for sip/rtp only)

    what i did notice was when i merged the rule "VOIP Adapter WAN" into an (In/Out) rule by using "any" it would not work!
    is this a bug or a feature?




  • hi

    i dont know if my problem is related to this one too

    the moment i updated my server to yesturday's snapshot, my son started complaining about audio latency and team viewer latency too.

    any reason why this is hapening,

    help really apreciated, i dont want to go back to 1.2.3, i need to practice the features in 2.0

    thank you

    hadi57


Locked