FreeDNS not updating?



  • 2.0-RC1 (amd64)
    built on Wed Apr 13 07:50:24 EDT 2011

    I can't get any of my freeDNS hostnames to update.  DynDNS hostnames update just fine.  I simply see the following pertaining to the freeDNS updates in the system logs:

    php: /services_dyndns_edit.php: phpDynDNS: (Unknown Response)
    php: /services_dyndns_edit.php: phpDynDNS: PAYLOAD: ERROR: Invalid update URL (2)
    php: /services_dyndns_edit.php: DynDns: Current Service: freedns
    php: /services_dyndns_edit.php: DynDns: DynDns _checkStatus() starting.
    

    I've been experiencing this issue for the last few weeks (I believe since the RC's started, but can't be sure).  Is anyone else seeing this or is it just me?



  • I'm seeing this behavior too, i'm running 2.0-RC1 (i386) built on Tue Apr 26 21:32:47 EDT 2011. My freedns update url is ok, it was working on pfSense 1.2.3

    Y.



  • It is telling you exactly whats wrong, invalid update url:

    @Boolah:

    php: /services_dyndns_edit.php: phpDynDNS: (Unknown Response)
    php: /services_dyndns_edit.php: phpDynDNS: PAYLOAD: ERROR: Invalid update URL (2)
    php: /services_dyndns_edit.php: DynDns: Current Service: freedns
    php: /services_dyndns_edit.php: DynDns: DynDns _checkStatus() starting.
    

    Confirm your update url, if it is correct contact them.



  • I can't respond for Boolah settings, but i'm seeing this behavior too, and my update url is correct, same url is working on 1.2.3.

    Y.



  • It looks like the fields in the GUI of pfSense for the freeDNS settings have changed.

    In older versions (again, I can't be sure exactly when the change took place), the "Hostname" field was populated with your freeDNS authentication token.  Now, you should enter your actual freeDNS hostname (i.e. hostname.afraid.org).  In older versions, the "Password" field was populated with your freeDNS web password.  Now, the "Password" field should be populated with your freeDNS authentication token for the corresponding hostname.  After updating these values, pfSense started updating freeDNS hostnames for me with the most recent version of pfSense (2.0-RC1 (amd64) built on Sun May 1 02:30:09 EDT 2011).



  • I figured it was something like that Boolah, I just dont have my 2.0 system active right now so I wasnt able to test it yesterday.



  • Boolah is right, now is working again, although the interface is confusing to FreeDNS.

    Thank you!

    Y.



  • I use release 1.2.3…the same error:

    May 31 01:01:02 	php: : phpDynDNS: PAYLOAD: ERROR: Invalid update URL (2)
    May 31 01:01:02 	php: : phpDynDNS: (Unknown Response)
    May 31 01:15:00 	check_reload_status: check_reload_status is starting
    May 31 06:03:01 	SnortStartup[27926]: Checking for needed updates...
    

    .. what they change (FreeDNS) ?

    Best Regards



  • I am using 1.2.3 as well and it is working. If you read your error it is telling you what is wrong: Invalid update URL. Confirm that it is correct, try to cycle your keys.



  • works :) was my fault .. i type a "wrong" key !! thx

    Best Regards


Locked