Connections to DMZ kicking me out



  • Hi

    I have a problem between my LAN and my DMZ, when I access the Server via it's private IP using SSH or IMAP/S it works perfectly, but When I switch to public IP from within my LAN (I can't reconfigure Mutt everytime I go in/out of my network so I use my domain name) the server closes the connection after 2/3 seconds whether there's activity or not, for example I login from LAN to DMZ via SSH using public IP (Port 22 already has the NAT forwared to 22 as well as the rule), I will be logged in successfully except after a couple seconds later the connect closes with (connection to example.com closed by remote host!), any idea why this is happening ??

    My config.xml

    Thx



  • Check DNS resolution on the server you are SSH'ing to.  This is common when SSHD cannot resolve the information.

    Or turn "UseDns no" on in sshd_config



  • @sullrich:

    Check DNS resolution on the server you are SSH'ing to.  This is common when SSHD cannot resolve the information.

    Or turn "UseDns no" on in sshd_config

    it didn't work, besides it's not only ssh, imap as well
    P.S: the domain name of the router is the same domain name i have, does it matter?



  • I tried re-installing (I took the snapshot this time) and it didn't work, a little more details about my network:

    as seen in the picture Server IP: 192.168.2.2, Laptop ip 192.168.1.2, All traffic from DMZ(192.168.2.1/24) to LAN (192.168.1.1/24) is blocked!

    Now If I try SSH or Telnet to any service to example.org (by domain name, so My laptop will get it as 2.0.0.2) the connection will be closed after 3/4 seconds of inactivity! however if i use SSH/Telnet but this time to 192.168.2.2 (by ip) then the connection will stay open…

    any solution ??

    Thx


Log in to reply