Pppoe connection on 2.0



  • I have been setback on the pppoe connection.
    I have installed several, including the 0226, release. All have the problem to establish pppoe connection to my ISP.
    I have did lots google search with no luck to find a solution. For example, one solution is to to disable the wan -> enable it to static IP ->  disable wan again -> enable wan as pppoe -> reboot.
    No luck for me.
    I went back to 1.2.3 release.
    By the way, 1.2.3 release have problem to classify voip traffics. Asterisk and Linksys ATAs can set tos to it's RTP stream. By default, the value is set to 184. But pfsense 1.2.3 classify these streams to qwanacks, not qvoipUp. Thus caused very bad voice quality when there have a huge download happened. One solution is to change the tos settings at asterisk configuration file and linksys ata configuration. Thus pfsense can have these stream send to qvoipUp queue.
    But I am wondering another problem. Since the tos has been changed, after these packages pass out of the pfsense to the internet, their will not be in identified as service need be low delay, high priority etc. And then cause bad service quality in the internet.
    Any clue?



  • Hello,

    I can't answer your question about VoIP as I don't use it, but I had a lot of problems achieving my PPPoE connexion to work as it should with pfSense 2 too.

    What's disturbing with PPPoE is that the configuration that finished to work for me is one that didn't work in my previous trials, and it's the simplest one ("activate PPPoE, enter your credentials and voila it works" ™ ). When it works it works very well, but it seems there's still space left for improvement in PPPoE configuration. I don't understand what finished to make it work, I made a lot of trials, with no "Reset to factory default" but with a lot of resets of interfaces settings, reboots, etc (the config was upgraded from 1.2.3).

    If a developer wanting to investigate read this, here are some observations I made:

    • interfaces are not always correctly reset when changing from/to PPPoE to/from anything else (packets are still sent/received with previous address); see http://redmine.pfsense.org/issues/1420
    • when PADI packets are emitted, sometimes Host-Uniq is not that good looking ("PPPoE PADI [Host-Uniq "@Q?."]" in tcpdump); I saw a lot of these when my connexion refused to work, but they were followed by correct looking ones with no more success in establishing connexion.
    • if changes are made to the PPPoE interface under Assign-PPPs, these are not reflected immediately (obvious when checking or not "Configure a NULL Service name"), PPPoE daemon still tries to establish connexion with old settings. A way to reset PPPoE daemon seems to set the interface the PPPoE connexion was assigned to to None; sometimes it works sometimes it doesn't (giving messages like "PPPoE: can't connect "[26]:"->"mpd17340-0" and "[3b]:"->"left": No such file or directory" in logs)
    • order of creation doesn't seem to really matters for me (directly setting WAN device to PPPoE or create PPPoE then assign)
    • I tried with 2.0RC official and with nightlies with no change in observations; it now works with 20110417042814 (that firstly exhibits the same non-working behavior as others build I tried)

    ChristOff



  • I have made lots of reinstall and reset to factory but with no success. But I have had successfully upgraded from 1.2.3 to 2.0 RC1 for ONCE, and only once!

    It's odd.



  • I have the same problem here. Upgraded from 1.2.3 to 2.0RC3. PPPoE interfaces only comes up when I change WAN interface type to 'none', save it, WAN Interface type to 'PPPoE', supplying PPPoE username and password and save. I have to repeat this after every reboot.

    I am running 2.0 RC3 Fri Jul 29 22:08:01 EDT 2011

    See also my original post.

    PPP lofile exerpt:

    Jul 30 19:34:29 ppp: [wan_link0] Link: reconnection attempt 42 in 4 seconds
    Jul 30 19:34:29 ppp: [wan_link0] LCP: Down event
    Jul 30 19:34:29 ppp: [wan_link0] Link: DOWN event
    Jul 30 19:34:29 ppp: [wan_link0] can't remove hook mpd8424-0 from node "[11]:": No such file or directory
    Jul 30 19:34:29 ppp: [wan_link0] PPPoE: can't connect "[11]:"->"mpd8424-0" and "[f]:"->"left": No such file or directory
    Jul 30 19:34:29 ppp: [wan_link0] Link: reconnection attempt 41

    I seems to be an upgrade problem because on my work I am running the same version on this hardware with PPPoE at the same provider.

    Reset to factory defaults did not solved the problmen even when I re-configure the firewall manually.

    Erik



  • I noticed some difference between the default config.xml (/conf.default/config.xml) and the config file after the upgrade (/cf/conf/config.xml):

    default config:

     <interfaces><wan><enable><if>vr1</if>
    
                            <ipaddr>dhcp</ipaddr>
    
                            <gateway></gateway>
                            <blockpriv><blockbogons><dhcphostname></dhcphostname>
                            <media></media>
                            <mediaopt></mediaopt></blockbogons></blockpriv></enable></wan></interfaces> 
    

    config after upgrade:

     <interfaces><wan><enable><if>pppoe0</if>
                            <blockpriv><blockbogons><spoofmac>00:00:c0:7a:bc:47</spoofmac>
                            <ipaddr>pppoe</ipaddr></blockbogons></blockpriv></enable></wan></interfaces> 
    

    Looks like I'm missing some fields?

    I also compared the /cf/conf/config.xml from the appliance at my work and the appliance at home. They are running exactly the same version 2.0RC 3 Fri Jul 29 22:08:01 EDT 2011. The only differnce between the two installations is that the appliance at home is upgraded from 1.2.3 to 2.0 RC3 and the appliance at my work is a preinstalled appliance updated to the latest 2.0 snapshot.

    config WAN interface / pppoe home:

     <wan><enable><if>pppoe0</if>
          <blockpriv><blockbogons><spoofmac>00:00:c0:7a:bc:47</spoofmac>
          <ipaddr>pppoe</ipaddr></blockbogons></blockpriv></enable></wan> 
    
     <ppp><ptpid>0</ptpid>
          <type>pppoe</type>
          <if>pppoe0</if>
          <ports>fxp1</ports>
          <username>xxxxxx@yyyyyy</username>
          <password>hdgvcfdr</password></ppp> 
    

    config WAN interface / pppoe work:

     <wan><if>pppoe0</if>
          <blockpriv><blockbogons><disableftpproxy><bandwidth>100</bandwidth>
          <bandwidthtype>Mb</bandwidthtype>
          <enable><spoofmac><ipaddr>pppoe</ipaddr></spoofmac></enable></disableftpproxy></blockbogons></blockpriv></wan> 
    
     <ppp><ptpid>0</ptpid>
          <type>pppoe</type>
          <if>pppoe0</if>
          <ports>vr1</ports>
          <username>xxxxxx@yyyyyy</username>
          <password>ksdfghkkldjsf</password>
    
          <bandwidth></bandwidth></ppp> 
    

    Is there still something wrong with the upgrade process as far as it concerns the pppoe configuration.

    Erik



  • Maybe can you give me interface sections from 1.2.3 and 2.0 upgraded and working version?



  • @ermal:

    Maybe can you give me interface sections from 1.2.3 and 2.0 upgraded and working version?

    Yesterday I did a fresh install of 2.0RC3 + latest snapshot. I configured the firewall manually, no old config file was imported. After completion I only ran the setup wizard to get a basic working installation. After that I rebooted. Still the same problems. I have to put the wan interface 'none', save it and reconfigure the PPPoE connection to get it up again. After every reboot I have to do the same procedure.

    So what I can do is the following. I have two identical IP330's here. On one I will do a fresh install of 1.2.3 (only setup wizard) and on the other I will do a fresh install of 2.0 with the latest snapshot (also only setup wizard).

    After that I can give you:

    dmesg of both systems
    ppp logs of both system
    config file of both systems

    Will this be enough information? I'll see if I can do this tomorrow or this week. I'll post the results when I'm ready.

    Erik



  • Yes it will do.



  • OK. I have done the work. I got four sets of information right now:

    • 1.2.3-Sun Dec 6 232136 EST 2009-IP330 (Fully working version)

    • 2.0RC3-Tue Jun 21 165025 EDT 2011-IP330. Working PPPoE after setup wizard. After reboot no working PPPoE connection. WAN reconfigure procedure needed to get PPPoE up and running.

    • 2.0RC3-Wed Aug 3 015450 EDT 2011-IP330. After reboot no working PPPoE connection. WAN reconfigure procedure needed to get PPPoE up and running.

    • 2.0RC3-Wed Aug 3 192443 EDT 2011-ALIX.2D13.  (Fully working version)

    Every set contains a backup of the device's config, ppp.log system.log and dmesg.boot. After cleaning usernames/passwords/external IP's.

    What sections of these files do you need? I can also mail them to you, think they're a bit big to publish on the forum.

    Can it be something with the network card drivers or updated MPP PPPoE deamon and/or hardware which is getting to old for the updated software, since 1.2.3 is working on my two IP330's and the fact that I have a fully working 2.0RC3 version on an Alix board at my office.

    Erik



  • Think I found some similar issues today.
    We created a new machine yesterday with the latest RC.
    We have a ppoe connection and set it up.  We did not check the dial on demand box and made no entry in the time out box.
    It connects with no problem.  Surf the web just fine.  Then we started setting up our vpn connections.  Never could get it to connect.

    Looked back in the support notes and had similar problems at this location before.  We were told to use an mtu of 1492 by the isp in the past so
    we decided to try that.  Then the fun begins.  When we entered the mtu sized and tried to save we were now required to enter a timeout value.
    So we checked the on demand and used 0 as it suggests.  Then we are able to save.  At this point things are still fine you can surf but not vpn yet.  So we decided to shut it all down and reboot.  When it comes back up the WAN interface is disabled.  Look at the screen for the wan and it does not show disabled but dashboard shows disabled and no internet connections.
    The only way I got around it was to use the console and reset to factory defaults.  The console shows the lan and wan ports still attached to their original settings.

    We went through this for several hours and as long as we did not change the mtu settings no problems with shutdowns and reboot.  As soon as we set a value in the mtu setting boom wan disabled.

    We have around 30 astaro and endian boxes out there and really want to move to pfsense.  What other information can we provide to help with this.

    THX

    LW

    Then we were having problems with vpn connections and in the past had used an mtu of 1492 for this provider.

    System showed no errors and conn


Locked