Squid on Multi WAN fix ???



  • Using the latest snapshot Fri Apr 22 23:35:53 EDT 2011

    As the topic says, I am looking for a fix/patch for getting Squid work on Multi WAN. I have tried the work arounds found in the old posts but that didn't work as expected.

    Will this be fixed in the later RC versions in near future?



  • no fix is needed …. it should work if you follow the post/comments made in the last couple of months



  • Anyone else?





  • It's works for failover. Not working for LoadBalance.



  • @asterix:

    It's works for failover. Not working for LoadBalance.

    I followed heper's guide, but instead of using a Failover Gateway, I used a LoadBalance Gateway (where all my WAN's are in Tier1).

    It actually works for me. My Setup is Captive Portal + Transparent Squid (with tons of cache) + Multi-WAN Load Balance. RC1 2.0 Apr 10, 2011.



  • Could you please share your floating rule screenshot?

    I am using HAVP, Squid, SquidGuard, Snort and LoadBalance on the latest pfSense snapshot.

    HAVP - Parent for Squid
    Squid - Transparent
    Snort - WAN1 enabled
    LoadBalance - WAN1 and WAN2 (Tier1)

    As per the guide, I do not need to put in NAT AON as it's been patched. I added the tcp_outgoing_address 127.0.0.1 under squid custom options. Also I have 3 VLANs (LAN, VoIP and Video). I selected all 3. Do I need to select loopback too?

    In one instance, it seemed it was working but I had to click on any page links twice to get further. That meant it failed the first time then the second time I clicked it went to the load balanced second gateway.



  • Can anyone please share their config for workaround/fix of getting Squid to work on Multi WAN? The guide is a bit confusing and I am not able to make it work.



  • yes i need it to! havp as parent for squid, squid transparent and multi-wan!
    there is at moment no solution for this


Locked