PPTP WAN broken going from 1.2.3 to 2.0RC1 ?



  • Hello,

    I've been trying to upgrade an existing and working 1.2.3 installation to 2.0RC1 but I seem to be stuck getting the PPTP WAN connection working properly again.
    While troubleshooting this, I've re-installed the proven-working 1.2.3. setup in the most basic configuration possible for me; just WAN, LAN (and a VLAN called LAN_V for the 'actual' LAN traffic; usually I have multiple VLANS on the LAN parent interface to also enable a WIFI and HOMEPLUG segment). This works just fine. Now, when I consequently either upgrade this existing 1.2.3 setup to 2.0RC1 or reinstall 2.0RC1 'from scratch' (replicating the settings/configuration of the working 1.2.3 setup) the PPTP doesn't work properly.

    Working not properly means that although the status->interfaces indicates that the PPTP link is 'up' (and has received an IP, ISP DNS etc.), whenever I try to access the internet from the LAN_V, there is trouble in the sense that the connection seems to drop a lot of packets. Whenever I for example visit a website, it takes very long to display (if that happens at all) a partial page. I've played with MTU sizes on the PPTP-WAN interface, I've tried different network cards (the working system was using a vr but I've also tried em and fxp but to no avail).

    sticking with 1.2.3. for now :-(
    any clues?

    thanks.
    A.


Locked