Questions about routing/miniUpnpd



  • I have installed miniUPNPd, and as far as I know I have it setup correctly (it's been installed and turned on for a while now), but it doesn't seem to be working. I have UPNP enabled in utorrent, but it never seems to open the ports in pfsense. With logging turned on, pfsense doesn't log any UPNP requests.

    I have also tried doing manual routing for a specific port under NAT for utorrent and it still doesn't forward that port, or at least utorrent reports as being behind a firewall.

    Another problem that I have is with the MTU. I tried setting up XBOX live via wireless, and it keeps failing on the MTU part. In pfsense it is set to max (1500), but it still fails.

    Any idea what I might be doing wrong?

    Pfsense is isntalled on a stand alone P4 system, with 3 nics (1 connected to cable modem, 1 for lan and 1 wireless (opt1).

    Thanks



  • I don't know for your upnp problem but maybe this can help you for making working your XBOX live! ;)

    With the specified settings in my post you should be able to clean the MTU problem. What's the link between ports and MTU ?
    Well, with my tests, I noticed that the XBOX try to check your MTU by joining a M$ server on the ports 3024 TCP/UDP or 88 UDP.
    But, first of all, the request seems to query a DNS server, and then the MTU-Check server through ports 3024 or 88. Don't know.
    So, if your DNS test pass, your MTU-Check depend on your NAT settings.
    And sometimes your will run 2 times the test and see : NAT STRICT, and now NAT OPEN.  :o
    I all case, your NAT is OPEN :)
    I think its just a bug of NAT detection from your XBOX because its use a remote server ;)

    To conclude MTU problem => NAT problem :P


Log in to reply