NAT problem with PPPOE on WAN (pfsense1.2.3).



  • Hi there,

    I am new to pfsense. After I spent more than one week trying pfsense, I found it very useful. I have successfully installed pfsense1.2.3 at my office, and used it as a simple firewall (doing NAT) between several office computers and a switch. I can access Internet from these office computes with on problems. I also succeeded in setting up captive portal, which is very impressive.

    However, when I tried to set up a pfsense firewall at home, I failed. I am using an ADSL modem to access Internet at home. I have two computes (called computer A and B). I installed pfsense1.2.3 on computer A. Computer A had three network cards, but only two of these network cards were used. One of these two network cards was set to WAN which connected to the ADSL modem. The other network card was set to LAN that connected to Computer B. The setting is shown as follows.

    ADSL modem <-> (WAN PPPOE) Computer A (LAN 192.168.1.1, DHCP server) <-> Computer B(192.168.1.100)

    I have followed all the instructions I could get from the pfsense website, and have set all the parameters as told. But after two days’ working, I still could not get it work. The situation is:

    (1)LAN is set to 192.168.1.1. DHCP server is enabled on LAN. The IP address Computer B was assigned is 192.168.1.100.
    (2)I can access Computer A from Computer B (using webconig, ping, etc.).
    (3)PPPOE on WAN is working. I can ping a public host (such as www.cisco.com) from Computer A.
    (4)When I check network status on Computer B, everything seem OK to me. The IP address, gateway, DNS servers (there are two DNS servers which I think were passed from WAN PPPOE)
    (5)LAN setting: I have set “Bridge with WAN”
    (6)Firewall rules:
       LAN:
       Proto Source Port Destination Port Gateway Schedule Description
       * LAN net * * * *   Default LAN -> any  
       WAN
       Proto Source Port Destination Port Gateway Schedule Description
       * * * * * * any->any
    (7)NAT setting:
        Outbound    
       Automatic outbound NAT rule generation (IPsec passthrough)
    (8)When I tried to ping www.cisco.com from Computer B, it showed that the IP address of www.cisco.com can be resolved, but there is no answer from the destination. This is very confusing.

    I have searched this forum for solutions, but no answers have been found. I really appreciate if anyone can give me any useful information to solve this problem. Thank you in advance!



  • Pfsense version I am using:
    pfSense-1.2.3-RELEASE-LiveCD-Installer.iso


Locked