• Hi, i am trying to install pfSense 2 to hard drive and i cant get anywhere.. I choose option 1 (Default at the first Menu (Also tried option 2), it then scrolls through a few lines of code and stops at: mountroot>

    on screen i see the following which i dont understand any of:

    Trying to mount from root cd9660:/dev/iso9660/dfSense
    acd0: FAILURE - READ_BIG HARDWARE ERROR asc=0x03

    Is this some known issue?


  • sounds like your CD.  I would suggest re-burning it at a slower speed.


  • Thanks, seems like it was the CD. But i now am stalled at another issue.. I have 3 NIC's, 1 onboard and  2 identical PCI NIC's.. at installation, it says i only have 1 valid interface: vr0

    How do i manage to get all 3 showing up so i can start install?


  • do you know who the chipsets on the cards are? if not, have you made it past the setup to be able to get to the shell?


  • I can't make it past the setup as whenever i choose 'a' for automatic it doesnt find anything when i connect a cable..

    not sure what chipset it is.. the 2 cards i have are these: http://www.microbarn.com/details.aspx?rid=102763#Specs

    EDIT: Its a Realtek chipset..

  • Netgate Administrator

    The automatic detection does not work for all ethernet devices unfortunately.
    Just assign vr0 to be LAN and finish the setup. Then you can assign the other devices from the web gui.
    If it turns out that your Realtek cards are not being recognised at all we can more easily work on that once you've completed the installation.

    Steve

    Edit: Looks like the Tenda TEL9901G is an rtl8139c+ which should be supported by the re(4) driver.

    Edit: What is your motherboard? Have you used these networks cards in it under another OS?


  • Hi steve thanks for the reply. The motherboard is a P7V800Pro -M V:3:0 (i think its an ASUS. not sure)

    THe NIC's io have just purchased new so havent tried them with another operating system as yet.

    Is is possible to just enter the vr0 as the LAN and then continue installing? It then asks for the WAN and i can;t see a way of getting past there..  If i could that would be great.

  • Netgate Administrator

    Ah yes my mistake.
    @pfSense:

    All interfaces are optional except WAN

    I've not tried this but it's supposed to be setup so you can use VLANs for you interfaces and therefore only require one NIC.
    Can you assign WAN only?
    Of course you'd have console access only until you brought up another NIC.

    Steve

    Edit: You may have to create some Vlans for now and delete them latter:

    I could get just the single NIC to work by creating 2 simple VLANs. VLAN 10 for WAN and VLAN 20 for LAN


  • Hi, i am new to all this so i am not sure how to do any of this. The first option it asks for is LAN, so i dont think i can get past this to just setup the WAN connection (am i right that the WAN connection is to my modem/router via ethernet to one of the routers LAN ports?)

    Vlans i will have to try that option.. see if i can get it to work

  • Netgate Administrator

    It's been a while since I ran the initial setup so I can't remember the exact wording either. However after you have entered the required interfaces it then says something like:
    'Enter an interface, press a to auto detect of press enter to finish'
    You want to finish.

    Does it actually not list re0 or re1?
    You could try entering that anyway.

    Yes your WAN interface would normally connect to your modem. If your modem/router has a built in switch then it would be correct to connect to one of the lan ports.
    Optimally you should set your modem to bridge mode so that your public IP gets passed to pfSense but we can work on that later!  ;)

    Steve

    Edit: You should probably try booting your board from a live linux cd to ensure that your cards work with your motherboard and there isn't some hardware mismatch that's throwing us off.


  • @stephenw10:

    Does it actually not list re0 or re1?
    You could try entering that anyway.

    Yes your WAN interface would normally connect to your modem. If your modem/router has a built in switch then it would be correct to connect to one of the lan ports.
    Optimally you should set your modem to bridge mode so that your public IP gets passed to pfSense but we can work on that later!  ;)

    Steve

    Edit: You should probably try booting your board from a live linux cd to ensure that your cards work with your motherboard and there isn't some hardware mismatch that's throwing us off.

    Hey Steve, thanks for all the help.It doesnt show up the NICs ata ll, just the 1 onboard vr0

    I just managed to get through by creating 2 VLAN's so i can try and attempt to install drivers for the NICs.. i have an issue, once the install went through i selete option 99 to install to hard drive (80GB SATA) it went through, i chose single processor kernal as i only have a P4, then it said it was about to reboot and to remove cd.. once i do this, it boots to a screen that says:

    F1 FreeBSD

    Option: F1

    When i hit enter, it does nothing.. just stalls.. can i not install to a SATA drive?

  • Netgate Administrator

    What if you press F1?

    If you wait long enough does it eventually give a kernel error?

    This is a common problem and it's usually caused by the bios incorrectly reporting the disk geometry to the bootloader. Once FreeBSD has booted it can read the geometry directly so it has no problem.
    Make sure your BIOS is up to date, this sort of error is commonly corrected by bios updates.

    Alternatively, as a work around, setting the disk to LBA mode instead of auto detect ofetn works.
    See: http://doc.pfsense.org/index.php/Boot_Troubleshooting

    Pata is less likely to cause you trouble if you have that option.

    Steve


  • Pressing F1 also does nothing, and it just sits there.. no error messages or anything..

    I will try the link you sent in a bit and report back


  • Ok, still no good.. my BIOS doesnt give that LBA option, only RAID or IDE, and its set to IDE.

    Not sure how to upgrade the BIOS, i dont even know who the manufacturer of the board is, just know the model name.. which a few seem to have the same.


  • The bios is displayed ( mostly ) in left bottom when it boots, or in the bios when you enter it.
    This code will tell yo who the manufacturer is, if you can't find it, open the box and look on the Motherboard itself

    If I was you I would go into the bios, and look around if you can find to load the defaults (fail safe) for it.
    Then untick anything else you don't need like paralel and serial ports, you have only a pata disc so disable the settings for sata or if on automatic if the MB can do both disable sata if you use a pata disk drive.

    So, then check if pc boots fine, get yourself for example the hiren cd to eventually test the hardware, like MemTest and check the Drive, a zerofill with DBAN is a good thing if this hard disk has been used in the past.

    Write the cd/dvd at 1x speed, then install again…

    Let me know, the result so we can rule out your other hardware other then the nics.


  • Hi Nicklas,
    I have loaded fail safe defaults and still no change. My Disk is a SATA 80gb drive.

    I already zerofilled the drive before i started this project with DBAN. I can't see how to update the BIOS, i cant even easily find the manufactrer of the board to work out how to do this.. its an old box that i got given to me.

    I have also reburned the iso at slower speed and still having this issue. Is there something i could have chosen incorrect when i went through the install to Hard drive?  no matter what i do i cant e past that boot part with the option: F1 FreeBSD


  • Get the Hiren v13.2 cd burn it and start with miniXP, then it will give you a lot of othr tools as well to check the hardware, because hiren has many of these tools on board. When the PC boots it should show you in left bottom corner a string with info, this info is to find out the manufacturere, when you got the box was it in a case for example dell or HP or so?  Have you disabled all other hardware in the bios you don't need to free up irqs like the 2 serial ports and printer port, look if the bios give option for pci settings and tell it to let the software find it…that helps sometimes as well. is that extra nic card pci or pci-x ? then careful with that option.

    http://www.hiren.info/pages/bootcd  gives you a overview of the tools to check your hardware, maybe if you boot with the miniXP if might show !!!! in the device manager or even give you some more clues about the hardware you have.

  • Netgate Administrator

    Is this it?

    http://www.phitronics.com.br/p7v80_4.php

    I don't speak Portuguese.  :P

    Steve

    Edit: It's almost certainly the same as this PCChips board the P23G.


  • Thanks Nicklas, i will check that out.

    Steve, i had also just found that and i am pretty sure it is the right board, i am in Brazil and speak Portugues, so i am guessing its the right one.

    I dont however have a clue how i am going th flash the bios as i have no floppy…

  • Netgate Administrator

    Reading through the manual for the pchips board, which is in English  ;), I can't see anything in the bios that jumps out at me. You must have the sata set to IDE mode. It should be detected in the first bios screen and there may be a way to set it from auto to manual, the manual doesn't show.

    Unfortunately some of these early SATA implementations, 2003, were a bit dodgy.
    I recently struggled to get a similar age Asus board to boot Linux from SATA. The bios code at the time just wasn't mature enough.

    If you have a pata HD use it.

    Steve

    Edit: Both sites have bioses available from mid 2007. If yours is still a 2003 bios you should update. You can do that from a bootable DOS CD.


  • Ill try and work out how to make a bootable DOS CD and see if i can flash the BIOS.. i guess that board wouldn't be able to boot from Thumb drive?

    I might try and install linux on this to see if it will work at all with this hard drive..

    EDIT: Just managed to install IPCop, and it boots into it after install.. so seems the system hardware can take a linux install.  Man, i really want to use pfSense..

    Also.. i should add, that i just noticed that when it starts up, the Boot part before going into the BIOS at the top it has the Mainboard model number P7800Pro and next to it is says 06/08/2007.. so i am guessing it already has the latest BIOS??

    Man, now i am really stumped..

  • Netgate Administrator

    Ah well that's good news.
    Does it correctly detect the two PCI cards under IPCop?
    It probably can boot from USB, it's not that old.

    So, it won't boot because of some FreeBSD bootloader quirk. Solution: Use a different bootloader.
    Grub presumably works if IPCop loads (are they using grub? It's been a long time) so you can use that. Alternatives are suggested in the boot troubleshooting page I linked to.

    Steve


  • Now you've lost me.. not really sure about the bootloader thingy.. is grub what is installed with pfSense??  It is a blank hard drive, so i havent installed anything, or have the know how to install a different bootloader..

  • Netgate Administrator

    By far the easiest thing you could do is use a PATA drive.

    The bootloader is what first runs after the bios. It loads and runs the OS.
    FreeBSD is complex and has several stages of loading. The output you are seeing "option F1 Freebsd" is from the first part of the loading sequence. It should automatically load and run the next part but for some reason it's not doing that. Probably because it can't find the code on the sata drive.
    By using a different bootloader that knows about SATA you should be able to get pfSense running. It's not easy though!  ::)

    Steve


  • I see, not easy and FreeBSD makes it really not easy for me then :)

    I just tried doing the install to a 8gb Thumb drive formatted to NTFS.. didn't work either.. But this one didn't even get as far as the reboot.. maybe cant use thumb drives either.  I'll have to see if i can get an IDE drive then.  Do you know how i might try to load a different bootloader?

  • Netgate Administrator

    Theoretically it would be something like:
    Install pfSense.
    Boot from a linux live cd, like Ubuntu.
    Install grub.

    However it's not something I've ever tried myself so I can't offer any advice on the specifics. I've just been Googling the topic and there doesn't seem to be much directly helpful info out there.

    Steve

    Look at this post about using the GAG loader. Looks pretty straight forward.
    Instruction on this blog. Not quite the same problem but hopefully the same solution.


  • Sometimes some linux flavours seems to have trouble with apci, maybe you could disable this in your bios and try again, but as said before you must check all settings in your bios, because it can be tricky sometimes. Please check if your bios gives option to set sata/pata to automatic and change it to sata only if you still try this with the original disk.

    http://www.techtalkz.com/freebsd/114125-how-disable-acpi-bootup.html


  • I'm starting to think there might be something wrong with the hardware here.. I have just installed Ubuntu on it and it still freezes from time to time..

    The BIOS doesnt give any SATA/PATA option.. just IDE or RAID.

    Going to get someone to check out the hardware for me now.. then i'll come back and let you know how its going. Thanks for all the support!!


  • Did you disable the ACPI?

  • Netgate Administrator

    The first option in the bios should look something like this:

    If you have selected the IDE option for SATA does it appear on that screen?
    If so you should be able to move the highlighted area down to it and press enter. Then you'll get some options, auto, manual, LBA, CHS, etc.

    It seems like you are having a very hard time. I hope it doesn't put you off using pfSense.

    Steve


  • Yes i have tried it with and without ACPI..

    On my BIOS, the only options i have for IDE or RAID (for the SATA Drive)

    So my screen reads something like:

    IDE Primary Master [DVD Drive]
    IDE Primary Slave   [None]
    SATA 1 [Hard Drive]
    SATA 2  [None]

    More or less that anyways.. I have run a memtest today and that passed fine, so hardware does seem to be ok. Have successfully been able to install Ubuntu 10.10 also.

    I have tried changing ll the options in the BIOS that i can think of..

    I am about to try another hard drive..  I am definately not put off using pfSense, i REALLY want this working.. Just starting to wish i had a better/newer box at hand to do it on..

    EDIT: I just tried one last installation with the existing hard drive, but this time i selected to do a custom install, and when it asked which kernel to use (Multiprocessor, Singleprocessor, custom) i selected the Custom one which said something about embedded vga and keyboard..when rebooted, this time it goes a little further that where i press F1 or Enter.. bust it still stalls a few lines after this. here is a what it says:

    F1 FreeBSD

    Boot:  F1
    /boot.config: D

    BTX loader 1.00 BTX version is 1.02
    Consoles: internal video/keyboard serial port
    BIOS drive A: is disk0
    BIOS drive C: is disk1
    BIOS 639kb/457664B available memory

    FreeBSD/i386 bootstrap loader, Revision 1.1
    (sullrich@FreeBSD_7.2_pfSense_1.2.3_snaps.pfSense.org, Sun Dec  6 22:34:04 EST 2
    009)

    Loading /boot/defaults/loader.conf

    And thats where it stalls.. any ideas?

    I am unable obviously here to install 1.2.3.. i dont have and blank cd's and its night here so is it possible for be to use the pfsense 2 .iso and create a bootable thumb drive to try installing that again? I am using windows 7 also here..


  • Only thing i can come up with is install this drive in other machine maybe nics as well and install there, then after install swap disk back and see if it will boot then, sorry no more ideas other turn the acpi off :-(( hmmmm, just think of pnp turn this of in the bios!! remove all unnecessary hardware like soundcard! and so on… turn of in bios ser port and paralel port..

  • Netgate Administrator

    Depending on what you selected the output may have switched to the serial console at that point. It may have continued to boot correctly. You certainly seem to be past the first stage bootloader.
    Do you have a serial cable suitable for looking at the console?

    Steve


  • Hey guys, getting further here but still having issues..

    Changed to an old IDE hard drive and the install goes through, and boots up to where i then need to create vlan's and whatnot.. but then the keyboard didn't work.. so i rebooted and tried another one but now it won't boot, goes to that mountroot> and no further.

    So i thought with the different keyboard i would do the install again from scratch, but when starting up to get into the install part, it says it can't find the cd image (same as i had when another disc didn't burn right). and ends at that mountroot> again.. so i dunno how the cd went from good to bad, but i will get another one from the shop tomorrow and try again.. still, more promising than it was a couple days ago.. must have not liked that SATA drive..


  • Could you try it with another cd-rom/dvd player, just in ccase something is wrong with that one?


  • Ok guys, so here is where i am at now.. Still not wanting to give up on pfSense, but more than a week just trying to get it installed is becoming annoying!

    I changed to an old IDE hard drive, and got a new cd to reburn the iso slower..

    I ran through the install, and it booted through from the hard disk all the way (first i got an LBA error so i disabled that in the bios) to where it asked if i wanted to create vlans.. but here, the keyboard no longer works.. although it did for me to press F1 to boot, and then to press enter at the first menu!!

    So i restarted the computer to see if it works now, and i now get the following, please see the screenshot/photo attached.. Mentions that the file system is dirty and something, its a clean install!! I even zero's the hard drive before doing anything with it..



  • Dirty file system just means the file system was not unmounted cleanly. In your case, I presume you weren't able to issue the shutdown command to unmount the file systems.


  • Correct.. I couldnt do anything as the keyboard wouldnt work.. as you see on that screenshot, thats where i am stuck at.. how can i get this working?  Why would the keyboard (PS2) work to boot into pfsense but then not work when i get to the point of creating the vlans?

    I rebooted and now i am stuck with the following screenshot.. man, seriously is it possible to actually get this installed? Can't possibly be this dificult!



  • Hmmm, maybe you could download again the pfsense.iso file and burn it low speed?
    nuke the HD first before you install, it might be your download is a bit corrupt, just maybe…


  • Sure i could.. i have however downloaded that iso twice and burned it 3 times at slowest speed my drive can burn it at(8x). have also tried 2 hard drives..