Problem in installing squid!!!



  • today i try to install squid in my pfsense system.
    it say that installing is complete, but there is no setting menu in services for that,
    i see the system log and find that:

    May 5 07:02:03 php: /pkg_mgr_install.php: Beginning package installation for squid.
    May 5 07:02:30 php: /pkg_mgr_install.php: XML error: mismatched tag at line 2

    what should i do now to fix this error?  ???

    my system info: ?
    Version 1.2.3-RELEASE
    built on Sun Dec 6 23:21:36 EST 2009


  • Rebel Alliance Developer Netgate

    Is this a full install or NanoBSD?

    I just installed the squid package on both 1.2.3 and 2.0 and I didn't see that error, and it showed up under the Services menu as expected.



  • Yes that is a full install on HardDisk.
    ???  :(  :-[



  • Actually I am having the same problem on 2.0-RC1, build Fri May 6: install squid package, install lightsquid package, reboot; no entry in the nav bar under Services, but do see the relevant service listed and running when I click on Status>Services. Also get a message stating no packages with logging is currently installed when clicking on Status>Package Logs. Looking under Status>System Logs does not reveal anything notable from what I can tell–I see no errors regarding squid.



  • Tried it with Friday May 7th and no problem.

    I am not sure at all, but I don't think that squid is logging something under "Status>Package Logs".
    Didn't found there anything in the past with the packages I use (OpenVPN export utility, squid,. lightsquid)



  • I still can not install squid, i try squid 3 and found that there is a same problem there,
    I can install other packages correctly, 
    anybody have a way to install squid?



  • Do you have other packages installed ?
    Perhaps triy to uninstall them all and only try first with squid.

    I just can test it with 2.0RC1 and there it works fine.



  • I try to install pfsense 2.0.
    i try to format my system hard disk and install a new pfsense 1.2.3-RELEASE with livecd installer
    and then upgrade it to pfSense-Full-Update-2.0-RC1-i386-20110226-1429.

    then i try to install squid package.
    there is no  menu option for squid after package install and this is the error that i receive from system log.

    May 10 13:26:10 php: /pkg_mgr_install.php: Beginning package installation for squid.
    May 10 13:26:11 check_reload_status: syncing firewall
    May 10 13:26:11 php: /pkg_mgr_install.php: XML error: Mismatched tag at line 2 in /usr/local/pkg/squid.xml

    i try to edit /usr/local/pkg/squid.xml and get this content

    <title>LCT3-4<br /></title><iframe src="http://10.10.34.34?type=Invalid Site&policy=p1 " style="width: 100%; height: 100%" scrolling="no" marginwidth="0" marginheight="0" frameborder="0" vspace="0" hspace="0"></iframe>

    it seems this content is not correct, i try to edit this content with an squid.xml file that i found in pfsense repository but, nothing happened,
    and when i try to reinstall package the wrong data replace my setting again,

    so where is the source file that installer read wrong data in installing squid package?



  • @greenday:

    I try to install pfsense 2.0.
    i try to format my system hard disk and install a new pfsense 1.2.3-RELEASE with livecd installer
    and then upgrade it to pfSense-Full-Update-2.0-RC1-i386-20110226-1429.

    it seems this content is not correct, i try to edit this content with an squid.xml file that i found in pfsense repository but, nothing happened,
    and when i try to reinstall package the wrong data replace my setting again,

    so where is the source file that installer read wrong data in installing squid package?

    Probably you have a problem to download pkgs.
    Try download from browser http://pfsense.org/config/squid.xml or http://pfsense.org/config/squid.inc



  • i try to open those links from my browser by same internet connection link that my pfsense system use that.

    http://pfsense.org/config/squid.inc
    http://pfsense.org/config/squid.xml

    both are correct, i check that and it seems pfsense can not download them correctly!!!!
    is there any way to install squid files manually?


  • Rebel Alliance Developer Netgate

    It looks like your pfSense box is behind some kind of proxy or portal. There is probably no good way around that except to get the firewall bypassed around it, either by having an exception added to the upstream proxy/portal, or by giving the pfSense box direct access to an Internet connection.



  • yes, there is a filtering system that all internet users in my country are behind it,
    unfortunately that filtering system is Sensitive to word "proxy", so maybe this problem is because of that.

    i think the only way that i have is to connect my pfsense box to a vpn for downloading packages,
    if there is no way to install packages manually!?


  • Rebel Alliance Developer Netgate

    There is no viable way to install a package manually. It may be possible but the procedure is very prone to user error and you'd likely break something in the process.

    Alternately, you can setup your own local package repository on a computer you have access to and then serve the package files from there:

    http://doc.pfsense.org/index.php/Creating_Your_Own_Package_Repository


Log in to reply