Tp-link tl-wn321g v4 usb wireless adaptor problem


  • hello

    pfsense supports the thinking of the USB wireless adapter I bought tplink tl-wn321g v4.

    problem is the following:

    during the first boot pfsense does not recognize the usb adapter.

    ugen4.2: <ralink>at usbus4
    run0: <1.0> on usbus4
    Root mount waiting for: usbus4
    run0: MAC/BBP RT3070 (rev 0x0201), RF RT2020 (MIMO 1T1R), address 74:ea:3a:95:2b:4e
    runfw: root not mounted yet, no way to load image
    run0: failed loadfirmware of file runfw
    run0: could not load 8051 microcode
    device_attach: run0 attach returned 6
    run0: <1.0> on usbus4
    run0: MAC/BBP RT3070 (rev 0x0201), RF RT2020 (MIMO 1T1R), address 74:ea:3a:95:2b:4e
    runfw: root not mounted yet, no way to load image
    run0: failed loadfirmware of file runfw
    run0: could not load 8051 microcode
    device_attach: run0 attach returned 6
    Trying to mount root from ufs:/dev/ad0s1a

    After the boot process, see the device when inserting the device off the back.

    run0: <1.0> on usbus4
    run0: MAC/BBP RT3070 (rev 0x0201), RF RT2020 (MIMO 1T1R), address 74:ea:3a:95:2b:4e
    run0: firmware RT2870 loaded

    pfsense every boot when I'm having this problem.

    I think there are drivers but could not figure out the problem. Is it possible to install pfsense to the driver?

    pfsense 2.0 rc1
    tl-wn321g tplink v4 (Ralink rt2020 or rt 3070)

    I wish you good day</ralink>


  • Add the line

    runfw_load="YES"

    to /boot/loader.conf.local to get the firmware loaded at boot time.


  • Thank you.

    The first problem is solved at the time of the boot.

    ip to the modem but can not ignore this time. I use the product as a wan.

    installed pfsense will do again.

    I do not understand there's a problem. realtek modem chip product is the same rope. tp-link does not.


  • kankabir, did you ever get this issue resolved?