Install/Upgrade 2.0 RC1 from CD/Web not working



  • Hi,

    I have a recently installed PFSense 1.2.3 and thought I'd move over to a new instalaltion of 2.0 RC1

    I downloaded 2.0 RC1 today and tried to install it several times by booting the CD. It gets to the stage where it says "ipsec: initialized security association processing" and then just hangs there.

    So, since 1.2.3 is still installed on the disk, I booted it and did the manual web update instead. It rebooted and then got stuck on the exact same stage but this time with the upgrade.

    Any ideas?

    Motherboard Jetway JNC9C
    3 x Intel NIC
    2 x Realtek NIC
    3.5" 120GB HDD

    | |




  • try to disable your acpi in bios



  • Thanks, you're right about the ACPI.

    A while ago I was trying to shut down the machine while it was hanging and noticed that as soon as I pressed the power button, instead of shutting down, the bootup process worked as normal. But, the ACPi is still enabled, it actually inerferes with all network functions and I can get no network connectivity.

    Everything works fine if I select option 2 (Boot with ACPI disabled) during bootup.

    I'm currently trying to modify /boot/device.hints by adding hint.acpi.0.disabled="1" but this isn't working..



  • Try this and let me know if it helps you.

    http://www.techtalkz.com/freebsd/114125-how-disable-acpi-bootup.html

    It says you need to do this see bottom almost

    Put hint.acpi.0.disabled="1" in loader.conf.

    should work then ;-)



  • Thanks, I tried that but it didn't work. Other sources say to modify device.hints, but I messed up my device.hints file! I downloaded it to my Windows PC and edited it in Wordpad then overwrote the original. I think it messed up the encoding/special characters. Anyone mind emailing/PMing their one to me?  ;D



  • if you did save the backup do a new reinstall, restore the config file after….

    Unless you have it remote in a DC :-((



  • I can't do a reinstall, when I try to do a fresh installation, it throws me onto the mountroot prompt and says there's some problems with mounting the USB CD drive. Not sure what to do from there…

    Only way I managed to do it before was to install 1.2.3 then upgrade to 2.0. If I could just fix the device.hints file I wouldn't need to start over (and loader.conf too, it seems I messed that I messed up loader.conf too  :-[  ). Anyone?



  • please try as follow, on the shell of the pfsense server type:  # dd if=/dev/urandom of=/dev/hda
    This will wipe your harddisk, then you should be able to do a clean install with noacpi parameter.

    otherwise DBAN the disk, try to do fresh install again with latest version.

    I assume you still have this acpi disabled, i can't recall if there is a option when you boot to start install,
    with most flavourse you can give options, like noacpi

    I have collected following over time when i faced problems:
    Options to use to install linux on laptops/desktops with power options or some other issues, [pnp settings in bios? [on/off]

    acpi=off
    noapic
    noiapic
    nomca
    nomce
    nosmp

    O, one more thing, burn that cd/dvd on 1x speed that might solve your issue as well !!!



  • Have you tried selecting Option 3 to boot from USB device while booting from the Install CD?  The boot process defaults to Option 1, select 3.

    I have acpi enabled on my NC9C, no issues.



  • I managed to fix it by using the "Edit file" command in the Web GUI to edit the devices.hints file and the load.conf.local files to disable ACPI. Thank you everyone for your help. (P.S. I burnt the disc at x1; didn't work, nor did selecting to Boot with USB device).



  • Hi Aziz, great to haer you got it all working now… so we can conclude it was down to the ACPI?

    regards
    N.


Log in to reply