PfSense slow on 100mbps WAN?



  • Hi all,

    I've got an internet side connection rated at 120mbps. The NIC in my pfsense box is only 100mbit though, but i'd still be expected 80 - 90mbit (considering I get 80 - 120mbps connected directly to the cable modem)

    However, pfsense can barely push through 46mbit or thereabouts. I run the squid package and I originally thought this may be impacting speed, but it doesn't seem to be. Even when not running through squid I still can't break 46mbit.

    For argument's sake, here's a speedtest connected directly to the modem: http://speedtest.net/result/1287609076.png

    and running through pfsense: http://speedtest.net/result/1287611867.png

    CPU load when pushing through 46mbit is around 50% and the RAM also around 50%, so eliminating those two would I be correct in saying it looks like at least one of my NICs could be faulty?

    EDIT: I'm running the bandwidthd, Squid, SquidGuard, vnstat and Dashboard packages on version 1.2.3. The box itself is an IBM ThinkCentre with a 2.8GHz celeron and 512MB of RAM.



  • I am not an expert in this but I run Alix boards on a 100Mbps connection (100Mbps NIC as well) and the highest I can get is about ~80Mbps. I think there is a threshold to the CPU or amount of data it can chunk. I am not sure if IP overhead is considered or not in these tests.

    I would suggest you plug your laptop directly to the provider port to test output. Or better yet use a computer with a 1000Mbps NIC port to test you do get 100Mbps.



  • Squid+SquidGuard can and do impact network performance.  Disable these when conducting your tests.  You also did not indicate the kinds of NICS you are using.


Log in to reply