Page fault while in kernel mode



  • pfSense Build:  2.0 RC1 i386, 20110509-0316

    Hello, folks.  I'm hoping someone may be able to help me out here.  I've got a router that is running 1.2.2 but seems to have an issue running 2.0 RC.  I've seen the same error on both 20110509-0316 snapshot from today as well as whatever build the official RC1 is.  Shortly after the bootloader starts, I encounter an error (image attached) stating that there was a page fault while in kernel mode.  The fault code is "supervisor write, page not present".  At first I thought it might be due to my system only having 96 MB of RAM, but the issue persists after having upgraded it to 256 MB which I believe is above the minimum requirements.

    Is there any other information I can provide which would prove useful?  Thank you.


  • Rebel Alliance Developer Netgate

    Have you tested the RAM to be sure it's good? I saw your other thread where this is quite old hardware (~15 years old) so it's hard to say if this is OS-related, BIOS related, hardware related, etc.

    Which kernel are you using? Have you tried the debug kernel?

    Was this installed to the HDD yet or running from the CD?



  • Hello!  Thanks for posting.  I'll attempt to answer your questions in order.

    The RAM hasn't had a formal memory test performed on it, but I do reliably see the same error with the same stop codes at the same point during loading with both the old (96 MB) and new (256 MB) sets of memory each time I attempt to boot.  There is no variation in errors received between boots or sets of RAM.  The upgrade sticks are also literally new/unused IBM modules.  I realize DOAs are always possible, but my point is mainly that this isn't old beater RAM that's been subject to ESD over the years and other handling hazards.

    I am using the regular uniprocessor kernel.  I haven't tried the debug kernel.  Are there instructions for how to use it?

    This instance was installed to the hard drive.  The system can't boot from non-emulated bootable CDs, so from disk the only way I can run pfSense.



  • I found an update for the BIOS of this board.  It turns out the motherboard is made by Intel for Gateway and is an Intel VS440FX (Manual).  With the latest BIOS available from 98/99 (1.00.11.CS1T), 2.0 still fails with the same error message.  I also upgraded to a Pentium Pro 200 1MB for performance reasons.  No change of course, but it was worth firing it up to check under the rare chance of a CPU issue with the old 180 256K I was using.

    Links added for future Googlers who might benefit.



  • Does anyone have any ideas of where I might check?  I'm going to try a different motherboard, but it's not like this one is unusual or anything.  It's a re-branded Intel reference board.


  • Rebel Alliance Developer Netgate

    Given that it's a 12+ year old board there probably isn't going to be much hope if you haven't found it by now.


Log in to reply