Port forwarding to print server loopback issue

  • I have a Netgear print server using port 9100 (Jetdirect) and an SSH server behind my pfSense box.  I've forwarded the ports from the external IP and am having mixed results.  First, let me say that this all worked very well with both my old Linksys and Netgear routers.  I was able to print and SSH into my box from both behind and outside of the router using the WAN IP address and loopback.

    The problem I'm having is that I cannot print from behind the router using the external IP address.  Printing from the outside works (even from behind another router), but when I send a print job to the printer from within, the packets get accepted, but they never seem to make it to the printer server.

    The SSH forwarding works just fine.  I've tried several things including enabling private addresses and adding yet another rule for the LAN interface, but I these didn't help and I don't see why they would when the SSH forwarding works well.

    I've been running pfSense for about three hours now and would like to keep using it if I can get around this problem.  I hope there is a solution.

  • Uncheck System -> Advanced -> Disable NAT Reflection

    Then the port(s) (port forwards) will be available from the LAN.


  • Already did that.  If I hadn't, the SSH forwarding wouldn't work.  I should have been clearer about that in my original post.

    Any other suggestions?

  • Try enabling static route filtering at system>advanced. I have heard this might help sometimes in a scenario like this.

  • That didn't help either.  Regardless of what I do, I can loopback into the SSH box, but the printing only works from external sources.

    Would any sort of diagnostic output help?  Like I said earlier, I'm very new to pfSense and really don't know how to diagnose these problems.

Log in to reply