Static Route does not work after upgrade from 1.2.3 to 2.0 rc1



  • Hello

    I have a physical box with ubuntu x64 as host o/s running vmware server 2.0 and 2 guest pcs (1 pfsense 1.2.3, 1 win2k3).
    Pfsense is set up with 3 virtual interfaces (1 lan, 2 wan).All interfaces are connected in bridge mode over 1 physical nic of the box (gigabit).
    All were working ok until i tried to upgrade from 1.2.3 -> 2.0 RC1.Pfsense kept all the configuration and the upgrade was almost successful except
    the fact that for some reason a static route that i had cannot be reached from the client side.I will give you a diagram to better understand my setup:http://imageshack.us/photo/my-images/39/diagramn.png/
    The subnet that i want to reach from client side is the 192.168.17.0/24 subnet.Although i can i reach it directly from pfsense box from client side
    i cannot (pfsense is the default gw on clients).
    I tried to delete gw on routes tab and recreate it among with static routes but when i try to do a traceroute from client pc it looks like pfsense
    ignores this static route and routes me through the internet!
    The only way that it can work is by creating a firewall rule on LAN interface with source lan subnet destination 192.168.17.0/24 through gateway 192.168.10.250 but is this normal?It shouldn't work with just the static route entry as before?

    P.S I have also installed openvm tools  package.

    thank you



  • You should add a rule on LAN before your the rule that does load balancing.
    For 2.0 there were changes done to avoid some other issues on 1.2.3 and possibly after 2.0 another solution will be implemented especially your issue.



  • Thank you Ermal for the tip!
    (faleminderit ;)


Log in to reply