TFTP package minor bug



  • Hi there !

    Well I'm currently running with 2.0RC (May 12 build) on alix with 1g cf card, and I installed TFTP package.

    But the minor thing I would like to report is the following :
    If you are in a scenario where another package, like snort, per example, is installed, and that you are on MAIN MENU > SERVICES > SNORT page, then if you click on MAIN MENU > SERVICES > TFTP, you will have a 404 http error, cause snort admin pages are in /snort webconfigurator directory, and I guess that the link to tftp service is something like [config_page].php instead of /[config_page].php

    Same issue when you are on tftp_files.php and you click on Files in the top left area.

    Kind regards.


  • Rebel Alliance Developer Netgate

    That shouldn't happen with current versions of TFTP, I moved the files a while ago.

    Snort has an open ticket for that.



  • Will add to this thread, that when enabling an interface for TFTP on System -> Advanced and go to second tab (firewall/NAT) at the botton. Here it is possible to choose one or more interface(s). But it is not possible to deselect again so none is choosen.

    Right now, after playing aroung, I am going for the OPT1 even though none is needed.


  • Rebel Alliance Developer Netgate

    That is the TFTP proxy, not the TFTP server package (which this thread is about). That can be deselected fine, just ctrl-click a line that is selected and the selection goes away. Same with any other multi-select box. I just tried it on a recent snapshot and it worked.



  • Oh… sorry about that.


Log in to reply