System tunables - Error in syslog but it works !?



  • Hi,

    I added and changed this parameter in "System tunables":

    kern.ipc.nmbclusters
    

    If I check this in the console the parameters are changed, but the syslog gives this output:

    php: /system_advanced_sysctl.php: The command '/sbin/sysctl kern.ipc.nmbclusters="65536"' returned exit code '1', the output was 'kern.ipc.nmbclusters: 65536 sysctl: kern.ipc.nmbclusters: Invalid argument'
    

    But this only happens, if I go to system tunables and click "apply changes". There is nothing in the syslog after a reboot.


  • Netgate Administrator

    Shouldn't that be in /boot/loader.conf.local  :-\

    See:http://forum.pfsense.org/index.php/topic,32744.0.html

    Steve



  • Not sure.

    I thought I could place all options in the "system tunable" tab if they are "sysctl" commands.
    I find it much more comfortable to put it in the GUI than in the loader.conf.local. I know that this command will work there, too.

    And it works if I place it in "system tunables" but it is displaying an error which - in my point of view - isn't an error.



  • There are a number of different constraints that apply to sysctl variables. Consider the following from my system:

    sysctl kern.ipc.nmbclusters

    kern.ipc.nmbclusters: 8000

    sysctl kern.ipc.nmbclusters=7999

    kern.ipc.nmbclusters: 8000
    sysctl: kern.ipc.nmbclusters: Invalid argument

    sysctl kern.ipc.nmbclusters="7999"

    kern.ipc.nmbclusters: 8000
    sysctl: kern.ipc.nmbclusters: Invalid argument

    sysctl kern.ipc.nmbclusters=8000

    kern.ipc.nmbclusters: 8000
    sysctl: kern.ipc.nmbclusters: Invalid argument

    sysctl kern.ipc.nmbclusters=8001

    kern.ipc.nmbclusters: 8000 -> 8001

    Looks like the only allowed modification to this parameter is to increase it (though there might also be a maximum value).


Log in to reply