Squidguard fails install



  • I have 1.2.3 release and squid installed and working. When I try to install Squidguard beta 1.4_3 pkg v.1.9 platform: 1.1 - it errors each time I try with :

    Fatal error: Cannot redeclare test_pfspkg() (previously declared in /usr/local/pkg/squidguard.inc:1400) in /usr/local/pkg/squidguard_configurator.inc on line 2453

    Tried reboot - any ideas ?

    Thanks



  • I am also getting the same error. Any idea how to resolve this



  • I am struggling with this very issue since last evening when I did a clean install. No matter which snapshot I use (Apr 10, May 1, current and a few others).
    Something is not right in the package. First I kept getting stuck at "Loading package instructions.." The installs won't move after that. It showed up as installed package after I cancelled the failed install and uninstalling it failed too.

    First it was squidguard, then it started to happen with Squid and LightSquid and finally with Snort package as well. Snort looked to be installed fine but when you click on the Snort link in the menu it came back with a Fatal error message.

    I have tried to do clean installed well over 10 times with the same results.



  • I can confirm that on 2.0 RC1 (AMD) I also find that squidGuard hangs at "Loading package instructions.." and I can not install it.

    I have not had any problems with squid or lightsquid though, they all installed fine.

    Ben



  • What about Snort? It installs fine but when you click on the menu to go into Snort settings, it gives a fatal error message.



  • I have not tried snort, so can;t comment on that.

    I have however just tried making a change to the traffic shaper, and in the Filter reload status, its now hanging with this message "Checking for nat PF hooks in package /usr/local/pkg/squidguard.inc…" which must mean the de install failed as well, and its not affecting other things.

    Ben



  • Things are back to normal. Did a clean reinstall and all package installs worked like a charm. Something was definitely not right in the package repository.


  • Rebel Alliance Developer Netgate

    Yeah there was an issue with the package repo yesterday morning, things have been fixed up since then.



  • Good to know. It was quiet frustrating when packages failed to install again and again despite clean installs.

    Is there a way to save all the packages locally on CD and install them offline?


  • Rebel Alliance Developer Netgate

    No, they must be installed online using a package repository server.

    You can run your own local package repository, but had you been doing that yesterday and kept it up to date with the official repo, it would have had the same problem.

    http://doc.pfsense.org/index.php/Creating_Your_Own_Package_Repository



  • Understood.

    Now only if there were a way to get this repository on the same pfSense box :D. It has the space and power.


  • Rebel Alliance Developer Netgate

    Search the forums, others have done that.

    I wouldn't want to do that, but to each their own…


Log in to reply