Lightsquid Error Report (Urgent)



  • Hi Everyone,

    I am using pfsense version 2.0RC1. This system is on the squid, lightsquid adn squidguard installed..Turned on the system log. Reflesh full, reflesh now clicked on buttons. But,  still I get an error as annexed. What is problem? Can you help me?

    Error;

    LigthSquid diagnostic.
    Error : report folder '/var/lightsquid/report' not contain any valid data! Please run lightparser.pl (and check 'report' folder content)
    Please check config file !
    Variable  value
    $tplpatph  /usr/local/www/lightsquid/tpl
    $templatename  base
    $langpatph  /usr/local/share/lightsquid/lang
    $langname  eng
    $reportpath  /var/lightsquid/report
    Access to '/var/lightsquid/report' folder  yes
    $graphreport  1
    folder content:

    For example config;

    1305981637.653    50 192.168.2.55 TCP_MISS/200 8676 GET http://static.hepsiburada.net/css/CssItems/Global.css? - DIRECT/193.28.225.212 text/css
    1305981637.670    41 192.168.2.55 TCP_MISS/200 2319 GET http://static.hepsiburada.net/scripts/_header_setup.js? - DIRECT/193.28.225.212 application/x-javascript
    1305981637.885    159 192.168.2.55 TCP_MISS/200 3067 GET http://images.hepsiburada.net/hbv2/Icn/naimage80.gif - DIRECT/193.28.225.212 image/gif
    1305981637.916    249 192.168.2.55 TCP_MISS/200 638 GET http://hepsiburada01.webtrekk.net/289941511384204/wt? - DIRECT/80.190.166.100 image/gif
    1305981637.923    173 192.168.2.55 TCP_MISS/200 6641 GET http://images.hepsiburada.net/hbv2/Icn/naimage200.gif - DIRECT/193.28.225.212 image/gif

    For example config;

    [2.0-RC1][admin@pfsense.localdomain]/var/lightsquid/report/20110521(15): ls -all
    total 50
    drwxr-xr-x  2 root  wheel    512 May 21 17:10 .
    drwxr-xr-x  3 root  wheel    512 May 21 17:10 ..
    -rw-r–r--  1 root  wheel    148 May 21 17:10 .bigfiles
    -rw-r--r--  1 root  wheel    130 May 21 17:10 .features
    -rw-r--r--  1 root  wheel    171 May 21 17:10 .group
    -rw-r--r--  1 root  wheel    22 May 21 17:10 .overuser
    -rw-r--r--  1 root  wheel    70 May 21 17:10 .realname
    -rw-r--r--  1 root  wheel    92 May 21 17:10 .total
    -rw-r--r--  1 root  wheel  33193 May 21 17:10 192.168.2.55
    [2.0-RC1][admin@pfsense.localdomain]/var/lightsquid/report/20110521(16): pwd
    /var/lightsquid/report/20110521
    [2.0-RC1][admin@pfsense.localdomain]/var/lightsquid/report/20110521(17):

    Good Days.



  • you have to generate some valid traffic for squid, then refresh lightsquid reporting, then refresh your browser page.  Should show up then.  I have had problems with firefox cashing the error page sometimes.



  • Thank you so much LostInIgnorance..The problem was as you say.I always worked with Firefox.
    Internet Explorer was able to see the report or trying to..Ohh god :(

    Thank you LostInIgnorance.
    Thank you LostInIgnorance

    :)

    Happy nice days.



  • @LostInIgnorance:

    you have to generate some valid traffic for squid

    How to do this?  ???
    Is it by simply clicking some pages or is it with another configuration?
    Sorry for my ignorance.



  • just browse a client that has to go through the squid proxy.  Like pull up pfsense.org. then refresh the data in lightsquid, then refresh the page in your browser for the report of lightsquid



  • @LostInIgnorance: I already tried that. I clicked the Refresh Now/Full and the Save buttons, I opened a webpage, refresh the page, refresh the lightsquid again but still no report. So I left my computer running overnight and in the morning i tried again and wallah, the report was already there.  :o I don't know what happened but there it is.

    The only thing that is not working is the Graph Report, I only have a blank page. Is there an additional tweak that I need to do before I can view the Graph?

    Sorry again for my ignorance and thank you LostInIgnorance.  ;D


Locked