Problems installing on 512MB Kingston CF



  • This is the first time I've tried to do an embedded install.  I have done a full install onto a PC with hard disk before with no problems.

    Here is what I've done:

    1.  Hardware is a FX5620 6 NIC Firewall/Router Platform from LinITX.com
    2.  CF card is a 512MB from Kingston.
    3.  I downloaded pfSense-1.0.1-Embedded.img.gz and physdiskwrite
    4.  I ran physdiskwrite on the downloaded embedded file and it seems to have written ok to the CF
    5.  Installed the CF in the FX5620, connected a keyboard and monitor and switched on.  The screen shows the following . .

    Searching for Boot Record from IDE-0..OK

    BTX Loader 1.00 BTX version is 1.01
        Consoles: internal video/keyboard
        BIOS drive C: is disk0
        BIOS 639KB/257024kB available memory

    FreeBSD/i386 bootstrap loader, Revision 1.1
        (sullrich@builder.livebsd.com, Sun Oct 29 01:30:00 UTC 2006)
        Loading /boot/defaults/loader.conf
        /

    ….. and that is as fas as it goes.

    What am I doing wrong?

    Thanks in anticipation.



  • You need to view the serial console for the output since this is an embedded image.



  • Doh!

    Thanks, and sorry for wasting your time!

    regards



  • other option is to install the pfSense (as opposed to the embedded version) version and change content of /etc/platform from pfSense to embedded . This gives you video.



  • Do I understand you correct if your suggestion is to use the livedisk install to hd option to install the image and then change to the embedded version?

    Or is there an install image I do not know of?



  • It's unsupported but should work. Use an IDE-CF-Adaptor to move a full install over to the cf-card. When it asks for swap partition delete it from the autogenerated partitionlist. After you finished the install change the  file like sai told you and reboot.


Log in to reply