2.0 RC2 MultiWAN gateway problem



  • I have 3 WANs set up, each on their own interface and one interface for the LAN. The problem is that the gateway that is selected as default is the only one which is routed traffic. Could someone please take a look at my config and find a problem?

    http://pastebin.com/13f6jppR



  • It woukd be easier if you could post us a screenshot of your LAN firewall rules and your Gateway groups.



  • No problem, thanks for the response. Here are the screenshots.






  • That explains it, in your firewall rules all of your LAN traffic is set to go throug the default (*) interface. You need to make a new firewall rule to pass traffic from LAN to your "Loaded" gateway (this rule should be on top of the one you currently have).

    It would be more easy if you edit your current rule and just replace "*" with "Loaded", that should route LAN traffic to your Loaded gateway group in a Round Robin manner.



  • @kevindd992002:

    That explains it, in your firewall rules all of your LAN traffic is set to go throug the default (*) interface. You need to make a new firewall rule to pass traffic from LAN to your "Loaded" gateway (this rule should be on top of the one you currently have).

    It would be more easy if you edit your current rule and just replace "*" with "Loaded", that should route LAN traffic to your Loaded gateway group in a Round Robin manner.

    Thank you, it is working great now! I should not have missed that.



  • Anytime :) Glad it worked.



  • 2.0 RC2  ???



  • @bouncer:

    2.0 RC2  ???

    Configuration is for pfsense 2.0
    In pfsense 1.2.3 there are no "Routing Groups" for LoadBalancing.


Locked