Impossible to add a default gateway outside attached subnets !



  • Okay, you will say this is not usual, but…  :P

    I have to run pfSense in a virtual machine on my server. This server is hosted by OVH which provide me some IP failover that work in XenServer/Vmware. The WAN configuration should be that one (as explained here : http://help.ovh.co.uk/BridgeClient / http://guides.ovh.com/BridgeClient) :

    IP: 86.95.150.79/32
    Default gateway: 45.15.95.254
    Satic route: 45.15.95.254/32 to 86.95.150.79

    The problem is that in pfSense you cannot add a default gateway outside the attached subnets, even if there is static route to reach it. I think this is wrong since it's possible in some configuration.

    I'm thinking to open an issue, what do you think ?  ???



  • Not a valid network config, but there are instructions in a feature request ticket in redmine.pfsense.org on how to make that work, not sure the ticket # offhand, look there and you'll find it.



  • @cmb:

    Not a valid network config, but there are instructions in a feature request ticket in redmine.pfsense.org on how to make that work, not sure the ticket # offhand, look there and you'll find it.

    Thank for your advise, the ticket is here: http://redmine.pfsense.org/issues/972

    Unfortunately, when I type :```
    route add -net gatewayip/32 -iface em0 -cloning

    
    Pfsense return me :```
    route: bad keyword: cloning
    

    So I tried without the parameter -cloning but I'm not an expert in routing/freebsd, so I don't know if it will really work as expected? Do there is any other way to add the clone flag on pfSense 2?



  • the -cloning option is no longer supported under FreeBSd 8.x
    It should work without the -cloning option


Log in to reply