Unable to register with SIP phone on asterisk server through pfSense



  • Well, i spent about 4 hours just now trying to get this to work. Result: I can register from home via IAX2 but not via SIP. So I guess something must be blocking my registration attempts. I read throught these forums and googled but i can't get it figured out.

    Situation:
    1.Asterisk server is in the office and works fine with inbound and outbound SIP and IAX calls.
    2.pfSense is our main gateway in the office and works fine for all the daily VoIP traffic
    3.Now i am home and i want to register on our asterisk server with a softphone

    I’m using a zoiper softphone from my home network to connect over the internet through pfsense in the office with vicidial. pfSense has two interfaces and I’m connecting with WAN2 which I have forwarded to my asterisk server:

    I have been searching over the internet and pfSense forums but couldn’t find much useful information. Most people want to connect with their sip phone from inside the LAN to an outside SIP server. But in my case I want to do the reverse, connect from outside-in. I read some discussions where people said SIP is messy protocol since it’s hard to NAT for some reason. Because of port rewrites you had to set the port to static in the manual outbound nat config of pfSense but with the latest version 2.0 which I am using I have read that it’s SIP compliant and that setting is not needed anymore.

    I have changed sip.conf of asterisk like this:

    Externip: 200.2.168.171
    Localnet: 192.168.1.0
    NAT=yes
    Canreinvite=no

    In pfSense this is what i get when i view states, I can see my IAX phone is registered but not SIP:

    I have tried resetting states and rebooting pfSense but to no avail.

    I also checked with pfTop (I don’t see anything in the 5000 port range, 190.98.12.92 is my home IP):

    The only real similar post to mine I could find: http://forum.pfsense.org/index.php/topic,8682.0.html

    Some people have had success with using siproxd, which is a SIP proxy package for pfSense, but again it seems to be more aimed for people who want to connect from the inside-out and not the other way around.
    I tried it out nevertheless but I could still not register with my SIP account.

    Any help would be greatly appreciated!


Log in to reply