OpenVPN Gateway replaces default gateway when it comes up



  • Hey guys. I looked for this specific problem and found nothing on it. Its possible my google-fu is weak recently so forgive me if it was posted before.

    So I got an OpenVPN provider to give me an american IP for netflix. Making it a gateway on OPT1 works great so all is well ,except that (following the setup instructions for StrongVPN) all my traffic wants to go through my gateway. I actually had to make a rule that all traffic that != a list of IPs would go out the normal WAN gateway. I tried to set a priority to the gateways, but you can only do that with a GW group as far as I can see. Can anyone give me some insight or things to look at? Don't worry about dumbing it down.

    EDIT: I forgot to mention the checkbox for default gateway is set on my WAN gateway and confirmed NOT checked on my OPT1 interface GW



  • That's because StrongVPN is pushing you a default route. You can override that.
    http://forum.pfsense.org/index.php/topic,36155.msg186479.html#msg186479



  • @cmb:

    That's because StrongVPN is pushing you a default route. You can override that.
    http://forum.pfsense.org/index.php/topic,36155.msg186479.html#msg186479

    Thanks for the reply! I tried the route-nopull added to the optional for my tunnel, but it didn't make a difference. I still need to make a statement in the lan rules to force anything that isn't meant for netflix goes to the WAN gw. Any other ideas?



  • That should do it (though can't say I've tried it, don't have a StrongVPN account, but that option works in general). What do your OpenVPN logs look like when you connect?


Log in to reply