Install Package with RRDTool Failure = No more RRDTool



  • I tried to install ntop and it failed because a package isn't available to download so it removes rrdtool completely from the system.

    Beginning package installation for ntop...
    Downloading package configuration file... done.
    Saving updated package information... done.
    Downloading ntop and its dependencies... 
    Checking for package installation... 
     Downloading http://files.pfsense.org/packages/8/All/ntop-4.0.1_1.tbz ...  (extracting)
       Downloading http://files.pfsense.org/packages/8/All/graphviz-2.28.0.tbz ...  could not download from there or http://ftp2.FreeBSD.org/pub/FreeBSD/ports/i386/packages-8.1-release/All/graphviz-2.28.0.tbz.
    of ntop-4.0.1_1 failed!
    
    Installation aborted.Backing up libraries... 
    Removing package...
    Starting package deletion for rrdtool-1.2.26_1...done.
    Starting package deletion for libart_lgpl-2.3...done.
    Starting package deletion for gdbm-1.8.3_3...done.
    Starting package deletion for perl-5.10.1_3...done.
    Starting package deletion for libpcap-1.1.1...done.
    Starting package deletion for GeoIP-1.4.7...done.
    Starting package deletion for font-util-1.2.0...done.
    Starting package deletion for ntop-4.0.1_1...done.
    Removing ntop components...
    Tabs items... done.
    Menu items... done.
    Services... done.
    Deinstall commands... done.
    Package XML... done.
    Configuration... done.
    Cleaning up... Failed to install package.
    
    Installation halted.
    

    And now the graphs error out with:

    php: /status_rrd_graph_img.php: Failed to create graph with error code 127, the error is: nice: /usr/local/bin/rrdtool: No such file or directory/usr/bin/nice -n20 /usr/local/bin/rrdtool graph /tmp/WAN-quality.rrd-4year.png \ --start 1180761406 --end 1307251006 \ --title "`hostname` - WAN :: Quality - 4 years - 1 day average" \ --color SHADEA#eeeeee --color SHADEB#eeeeee \ --vertical-label "ms / %" \ --height 200 --width 620 \ --lower-limit 0 \ DEF:delayraw=/var/db/rrd/WAN-quality.rrd:delay:AVERAGE \ DEF:loss=/var/db/rrd/WAN-quality.rrd:loss:AVERAGE \ "CDEF:delay=delayraw,1000,*" \ "CDEF:roundavg=delay,PREV(delay),+,2,/" \ "CDEF:loss10=loss,1,*" \ "CDEF:r0=delay,20,MIN" \ "CDEF:r1=delay,60,MIN" \ "CDEF:r2=delay,180,MIN" \ "CDEF:r3=delay,420,MIN" \ COMMENT:"	 Delay	 Packet loss\n" \ AREA:delay#990000:"> 420 ms" \ GPRINT:delay:MIN:"	 Min\: %7.2lf ms" \ GPRINT:loss:MIN:"	Min\: %3.1lf %%\n" \ AREA:r3#a83c3c:"180-420 ms" \ GPRINT:delay
    

    So I go check…

    [2.0-RC2][admin@x]/usr/local/bin(31): ls
    2to3                           idle2.7                        php
    2to3-2.6                       ipsecstats                     ping_hosts.sh
    2to3-2.7                       jpegexiforient                 pkg-config
    3gstat                         jpegtran                       pngtogd
    annotate                       kill_ghosts.sh                 pngtogd2
    athstats                       libpng-config                  pydoc
    autopoint                      libpng14-config                pydoc2.6
    barnyard2                      links                          pydoc2.7
    bdftogd                        lua50                          python
    beep                           lua50c                         python-config
    beep.sh                        lua50c51                       python-shared
    captiveportal_gather_stats.php mbchk                          python-shared-config
    cjpeg                          minicron                       python-shared2.6
    cpdup                          mkfontdir                      python-shared2.6-config
    create-sidmap.pl               mkfontscale                    python-shared2.7
    cryptokeytest                  msgattrib                      python-shared2.7-config
    cryptostats                    msgcat                         python2.6
    cryptotest                     msgcmp                         python2.6-config
    djpeg                          msgcomm                        python2.7
    easyrule                       msgconv                        python2.7-config
    envsubst                       msgen                          rate
    event_rpcgen.py                msgexec                        rdjpgcom
    exifautotran                   msgfilter                      recode-sr-latin
    fc-cache                       msgfmt                         runmsntp.sh
    fc-cat                         msggrep                        safestats
    fc-list                        msginit                        slowdownpipe.sh
    fc-match                       msgmerge                       smtpd.py
    fc-query                       msgunfmt                       smtpd2.6.py
    fc-scan                        msguniq                        smtpd2.7.py
    filterparser.php               mysql                          snort
    freetype-config                mysql_config                   snort_rename.pl
    gd2copypal                     mysql_fix_privilege_tables     ubsecstats
    gd2togif                       mysql_upgrade                  viconfig
    gd2topng                       mysqladmin                     voucher
    gdcmpgif                       mysqlbinlog                    webpng
    gdlib-config                   mysqlbug                       wol
    gdparttopng                    mysqlcheck                     wrjpgcom
    gdtopng                        mysqldump                      xft-config
    gettext                        mysqlimport                    xgettext
    gettext.sh                     mysqlshow                      xml2-config
    gettextize                     mysqlslap                      xmlcatalog
    giftogd2                       mysqltest                      xmllint
    gm4                            ngettext                       xmlwf
    hifnstats                      oinkmaster.pl                  zmq_forwarder
    iconv                          pcre-config                    zmq_queue
    idle                           pcregrep                       zmq_streamer
    idle2.6                        pcretest
    
    

    No more rrdtool.  I've experienced this in three different snapshots, including current.  It's completely reproducible.

    For anyone reading this with the same issue, ssh into the pfsense box and do```
    pkg_add -r rrdtool

    [2.0-RC2][admin@x]/usr/local/bin(37): pkg_add -r rrdtool
    Fetching ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-8.1-release/Latest/rrdtool.tbz... Done.
    pkg_add: package 'rrdtool-1.4.3' or its older version already installed

    then do this:
    

    rm -rf /var/db/pkg/rrdtool-*
    pkg_add -r rrdtool



  • it fails looking for graphviz-2.28.0.tbz here:
    http://files.pfsense.org/packages/8/All/ which isn't there, but it seems that graphviz-2.26.3_3.tbz is, with a date of April 4, 2011



  • Yeah, is there a way to get the package to look for that file instead of the new one?


  • Rebel Alliance Developer Netgate

    Should hopefully be fixed soon. I pushed a commit a few minutes ago, it should sync over in the next 5 minutes or so.

    Not sure why the updated graphviz package didn't upload, I'll have to look into that later. For the time being I pointed it to the older version of the library.


  • Rebel Alliance Developer Netgate

    Looks like it's still trying to pull the new version even if the old one is installed. It'll have to wait until after the next full package builder run, which will happen overnight.



  • Thank you, I appreciate you looking into it.  :D


  • Rebel Alliance Developer Netgate

    Should be OK again now. I just installed it on a VM and it's up and running.



  • Worked on my running install, thank you :)


Locked