2.0 RC2 and some bugs



  • Version:
    2.0-RC2 (amd64)
    built on Sun Jun 5 05:01:44 EDT 2011

    The last version worked fine but today i did my monthly update and got the well known error:
    "Packages are currently being reinstalled in the background.
    Do not make changes in the GUI until this is complete."
    I thought this bug was solved.

    An other problem is the NRPE2 daemon. The nrpe daemon lost the config after the update. This is a bug ok. The second problem with nrpe is the hardcoded command menu in the gui. I think a better idea is the read the menu dynamic from the files in the plugin folder. After the update i had to reconfigure nrpe und also its commands.


  • Rebel Alliance Developer Netgate

    If you saw the message that packages are reinstalling, then either one failed to reinstall or one is actually still installing. On current snapshots you can clear the lock by going to Diagnostics > Backup/Restore and pressing the button to clear the package lock.

    I haven't seen nrpe2 lose its settings but I have only tested with it in a limited capacity. I had it installed some time ago when testing and I reinstalled it now and it had kept all of my settings.

    The dynamic command/plugin list is a good idea though.



  • Today i did also a upgrade and there was no problem with loosing data from the nrpe config.
    The package reinstalling is in my eyes a big problem. I think this should be logged into a differnt section. In the system logs i can't see it because the system logs are full with all other things.
    After the todays update there was no package lock. So i think all worked ok.


  • Rebel Alliance Developer Netgate

    The package reinstall happens on the console if it's done during an upgrade - it's not logged. If you want to check the progress, look at the console (Video, Serial, etc)

    It was probably just a temporary error of some kind. These kinds of problems are only an issue on snapshots because people update so often. In the future it won't really be as much of an issue because once people are on the 2.0 release they may not upgrade again until 2.1.


  • Rebel Alliance Developer Netgate

    Just pushed a new version of the nrpe package. It should be pulling the list of commands dynamically now from the contents of the directory. It lists anything starting with check_*.



  • Ok i tried the new nrpe version but i think this version is broken.

    On the screenshot you see that this could not be ok.


  • Rebel Alliance Developer Netgate

    If you view the source of that page, is there a PHP error stuck in the middle of all that?

    It worked when I installed it, but I may need to add some safety checks.



  • I found this in the source:

    Fatal error: Call to undefined function nrpe2_get_commands() in /usr/local/www/pkg_edit.php(894) : eval()'d code on line 1


  • Rebel Alliance Developer Netgate

    Yeah I managed to reproduce it on another VM. I just pushed a fix, should be up in ~5 minutes. Reinstall the package again then.



  • Thank you i will try the new package.



  • It is working now and looks very well.


  • Rebel Alliance Developer Netgate

    Good to hear. Hopefully it keeps working well. :-)



  • Ok, so this is the relevant post, but not the relevant section of the forum.

    I am having this same issue, but with 1.2.3-RELEASE. In the NRPE service page, the command drop down field is missing. Any thoughts, Jimp?


  • Rebel Alliance Developer Netgate

    Upgrade to 2.0 :-)


Log in to reply