Please help me



  • Hello all,

    I'm newbie to pfsense.
    I setup pfsense on VMware.
    Everything is fine but I can't access to my modem.
    I use satellite modem with IP 172.25.25.100.
    I can ping to modem but I can't access to modem's web panel.

    I install squid with transparent mode and listen on port 8080.
    Modem web port is also 8080. Is it a problem?

    Please help me.



  • They cannot both listen on the same IP, post more info I will try to help



  • Thanks for replying.

    I will show my setup.

    172.25.25.100 –------ 192.168.123.1 (VOIP+Router) --------- Pfsense ( WAN 192.168.123.150, LAN 192.168.100.2 ) -------- Clients ( DHCP 192.168.100.100 to 150 )
    Sat: Modem

    I want to access Sat Modem's web control panel. Which URL is http://172.25.25.100:8080/



  • on pfSense, can you go to the shell/console via SSH and type:

    netstat | grep "8080"

    any results? Sounds like you may have to change the port for squid



  • When I type

    netstat | grep "8080"

    on shell, it took a lot of time and take no result. Like following

    [2.0-RC1][localhost]/root(2): netstat | grep "8080"
    [2.0-RC1][localhost]/root(3):



  • Ok, try to change the squid port from 8080 to say 8081. I don't know too much about squid but see if that fixes your problem.



  • Changed to 8081 and default squid port 3128 and retry.
    But nothing change.
    :(

    Another way?

    Thanks



  • Yes, I took a look at your diagram again.

    I think I see an issue. What type of VOIP/Router is being used between the SAT modem and pfSense?



  • It has no brand name. Part of IPStar service.

    Sat Modem ip is 172.25.25.100 with DHCP.
    Voip router WAN side get 172.25.25.101 from Sat modem.
    Voip router LAN address is 192.168.123.1 with DHCP.
    PFSense get 192.168.123.150 from Voip router.
    Like this

    172.25.25.100 –------ 172.25.25.101 (VOIP+Router) 192.168.123.1 --------- 192.168.123.150  ( Pfsense ) 192.168.100.2 -------- Clients ( DHCP 192.168.100.100 to 150 )

    If I replace pfsense box with another computer, I get 192.168.123.151 from Voip router
    and I can access modem's panel.

    172.25.25.100 -------- 172.25.25.101 (VOIP+Router) 192.168.123.1 --------- 192.168.123.151 ( Another Computer )



  • @aungzawmoe:

    It has no brand name. Part of IPStar service.

    Sat Modem ip is 172.25.25.100 with DHCP.
    Voip router WAN side get 172.25.25.101 from Sat modem.
    Voip router LAN address is 192.168.123.1 with DHCP.
    PFSense get 192.168.123.150 from Voip router.
    Like this

    172.25.25.100 –------ 172.25.25.101 (VOIP+Router) 192.168.123.1 --------- 192.168.123.150  ( Pfsense ) 192.168.100.2 -------- Clients ( DHCP 192.168.100.100 to 150 )

    If I replace pfsense box with another computer, I get 192.168.123.151 from Voip router
    and I can access modem's panel.

    172.25.25.100 -------- 172.25.25.101 (VOIP+Router) 192.168.123.1 --------- 192.168.123.151 ( Another Computer )

    in pfSense, go in to the WAN interface and uncheck the option for block private IPs then save and try it now.

    That should fix it. Just realized 172.16.0.0 through 172.31.0.0 range is private.



  • :( :( :( :( :(
    Already tried. Can't solved.

    I think there has no way to resolve.



  • Ok, well I will give it some more thought and figure out where the issue is. We'll figure it out, don't worry.



  • Ok, what about the VOIP Adapter/Router, can you login to that admin page from the LAN side of pfSense? Trying to figure out where it's happening.



  • Have you considered testing by removing the VOIP Router and connecting pfSense WAN directly to the sat modem, you can always use DHCP/NAT in pfSense.

    If you need VOIP, connect the VOIP Router in after pfsense.

    At least try this to test. Also, is the gateway properly set in pfSense for the WAN interface?



  • Ok, I will test and report.

    Thanks


Locked