Problems since latest firmware 2.0-RC2 (amd64) built on Wed Jun 8



  • Hi folks,

    yesterday evening I updated my pfsense to "2.0-RC2 (amd64) built on Wed Jun 8 17:13:48 EDT 2011" as I have done before several times without having any problems. Rebooting the new firmware everything looked normal: for em0 I got assigned my publicIP from my provider and em1 was set to my local 192.168.x.y but starting a browser gave me an error, that I had no connection to the Internet. Only connections within LAN were possible. Corresponding to this error pfSense´s version check gave a "Unable to check for updates."-feedback. As I had defined no snapshot at virtualbox I had to reinstall the last version I had on my harddrive (2.0-RC1 (amd64) built on Sat Feb 26 18:07:23 EST 2011). At least I had a backup from the configuration.

    So today I defined the snapshot and tried to install the new firmware again resulting with the same errors. Are there any features added with this release which require me to change something in my configuration or is there a bug that had crept in?

    As alternative it would be great to have the - for my scenario - last working firmware (2.0-RC2 (amd64) built on Wed Jun 7) again. I found the newest and the one I am using atm only.

    Thanks for your help,
    greetz
    plex



  • check your routing and gateway config.
    make sure a gateway is assigned to the em0



  • found this link
    http://snapshots.pfsense.org/FreeBSD_RELENG_8_1/amd64/pfSense_HEAD/updates/?C=M;O=D

    with this firmware
    pfSense-Full-Update-2.0-RC1-amd64-20110607-1316.tgz 07-Jun-2011 15:19 100M
    although its labled to be RC1 in fact it is RC2. Further attempts to upgrade firmware will be following…



  • using the firmware "Fri Jun 10 15:22:58 EDT 2011" have the same effect…



  • Check your DNS servers?  Check System => Generel Setup?



  • I had the exact same issue. Every setting seems fine. It connects to PPPoE and gets an IP, can ping the gateway, but it seems like the firewall is blocking 100% of packets going out or coming in through the WAN interface. Tried disabling the firewall by setting allow any-any, no go. Ended up throwing the install CD in there an re-installing it from scratch.



  • By the way I have verified that doing the update will bring the same issue back, so it seems that the build is broken somewhere along the line. Thankfully re-installing and restoring the settings works :D



  • I also have been impacted by this AMD64 issue.



  • Hi All

    I have the same issue:

    Just did a update

    2.0-RC2 (i386) built on Tue Jun 14 17:27:27 EDT 2011
    Unable to check for updates.



  • using the firmware "2.0-RC2 (amd64) built on Sat Jun 18 01:57:22 EDT 2011" solved my problems…

    first difference compared to "2.0-RC2 (amd64) built on Wed Jun 8 17:13:48 EDT 2011" I detected was while booting pfsense it took quite a long time to start the openNTP client.


Locked