Problem detecting multiple NICs of the same type



  • Greetings,

    I currently have a pfSense box with 1x 10/100 built-in NIC, 1x 10/100 PCI NIC (D-Link DFE-520TX), and 2x 10/100/1000 Gigabit PCI NIC (Both D-Link DGE-528T). The setup is already working with the built-in NIC and the 10/100 PCI NIC being used as WAN1 and WAN2, while 1 of the 2 Gigabit PCI NICs being used for LAN. The problem I'm having is that the other Gigabit PCI NIC is not being detected by pfSense. I've already tested the card that's not being detected and it's working fine. I've also tried rearranging the cards to no avail. The cards being detected are labeled as vr0, fxp0, and re0. I was expecting pfSense to detect the other Gigabit NIC as re1 but it didn't. Any thoughts would be greatly appreciated.

    Thank you very much and Best Regards



  • Please post the output of the pfsense shell comand # dmesg

    Perhaps the startup is reporting a problem with the "missing" NIC.



  • Greetings again. Here is the output:

    $ dmesg
    Copyright © 1992-2009 The FreeBSD Project.
    Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
    The Regents of the University of California. All rights reserved.
    FreeBSD is a registered trademark of The FreeBSD Foundation.
    FreeBSD 7.2-RELEASE-p5 #0: Sun Dec  6 22:57:48 EST 2009
        sullrich@FreeBSD_7.2_pfSense_1.2.3_snaps.pfsense.org:/usr/obj.pfSense/usr/pfSensesrc/src/sys/pfSense.7
    Timecounter "i8254" frequency 1193182 Hz quality 0
    CPU: Intel(R) Pentium(R) 4 CPU 3.00GHz (3000.52-MHz 686-class CPU)
      Origin = "GenuineIntel"  Id = 0xf41  Stepping = 1
      Features=0xbfebfbff <fpu,vme,de,pse,tsc,msr,pae,mce,cx8,apic,sep,mtrr,pge,mca,cmov,pat,pse36,clflush,dts,acpi,mmx,fxsr,sse,sse2,ss,htt,tm,pbe>Features2=0x441d <sse3,dtes64,mon,ds_cpl,cnxt-id,xtpr>Logical CPUs per core: 2
    real memory  = 536084480 (511 MB)
    avail memory = 510234624 (486 MB)
    ACPI APIC Table: <sec   ="" oemapic="">FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
    cpu0 (BSP): APIC ID:  0
    cpu1 (AP/HT): APIC ID:  1
    ioapic0 <version 2.0="">irqs 0-23 on motherboard
    wlan: mac acl policy registered
    kbd1 at kbdmux0
    cryptosoft0: <software crypto="">on motherboard
    padlock0: No ACE support.
    acpi0: <sec magic="">on motherboard
    acpi0: [ITHREAD]
    acpi0: Power Button (fixed)
    acpi0: reservation of 0, a0000 (3) failed
    acpi0: reservation of 100000, 1ff00000 (3) failed
    Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
    acpi_timer0: <24-bit timer at 3.579545MHz> port 0x808-0x80b on acpi0
    pcib0: <acpi host-pci="" bridge="">port 0xcf8-0xcff on acpi0
    pci0: <acpi pci="" bus="">on pcib0
    agp0: <intel 82865="" host="" to="" agp="" bridge="">on hostb0
    pcib1: <acpi pci-pci="" bridge="">at device 1.0 on pci0
    pci1: <acpi pci="" bus="">on pcib1
    vgapci0: <vga-compatible display="">mem 0xfd000000-0xfdffffff,0xe8000000-0xefffffff irq 16 at device 0.0 on pci1
    uhci0: <intel 82801eb="" (ich5)="" usb="" controller="" usb-a="">port 0xe000-0xe01f irq 16 at device 29.0 on pci0
    uhci0: [GIANT-LOCKED]
    uhci0: [ITHREAD]
    usb0: <intel 82801eb="" (ich5)="" usb="" controller="" usb-a="">on uhci0
    usb0: USB revision 1.0
    uhub0: <intel 1="" 9="" uhci="" root="" hub,="" class="" 0,="" rev="" 1.00="" 1.00,="" addr="">on usb0
    uhub0: 2 ports with 2 removable, self powered
    uhci1: <intel 82801eb="" (ich5)="" usb="" controller="" usb-b="">port 0xe400-0xe41f irq 19 at device 29.1 on pci0
    uhci1: [GIANT-LOCKED]
    uhci1: [ITHREAD]
    usb1: <intel 82801eb="" (ich5)="" usb="" controller="" usb-b="">on uhci1
    usb1: USB revision 1.0
    uhub1: <intel 1="" 9="" uhci="" root="" hub,="" class="" 0,="" rev="" 1.00="" 1.00,="" addr="">on usb1
    uhub1: 2 ports with 2 removable, self powered
    uhci2: <intel 82801eb="" (ich5)="" usb="" controller="" usb-c="">port 0xe800-0xe81f irq 18 at device 29.2 on pci0
    uhci2: [GIANT-LOCKED]
    uhci2: [ITHREAD]
    usb2: <intel 82801eb="" (ich5)="" usb="" controller="" usb-c="">on uhci2
    usb2: USB revision 1.0
    uhub2: <intel 1="" 9="" uhci="" root="" hub,="" class="" 0,="" rev="" 1.00="" 1.00,="" addr="">on usb2
    uhub2: 2 ports with 2 removable, self powered
    uhci3: <intel 82801eb="" (ich5)="" usb="" controller="" usb-d="">port 0xec00-0xec1f irq 16 at device 29.3 on pci0
    uhci3: [GIANT-LOCKED]
    uhci3: [ITHREAD]
    usb3: <intel 82801eb="" (ich5)="" usb="" controller="" usb-d="">on uhci3
    usb3: USB revision 1.0
    uhub3: <intel 1="" 9="" uhci="" root="" hub,="" class="" 0,="" rev="" 1.00="" 1.00,="" addr="">on usb3
    uhub3: 2 ports with 2 removable, self powered
    ehci0: <intel 82801eb="" r="" (ich5)="" usb="" 2.0="" controller="">mem 0xfebffc00-0xfebfffff irq 23 at device 29.7 on pci0
    ehci0: [GIANT-LOCKED]
    ehci0: [ITHREAD]
    usb4: EHCI version 1.0
    usb4: companion controllers, 2 ports each: usb0 usb1 usb2 usb3
    usb4: <intel 82801eb="" r="" (ich5)="" usb="" 2.0="" controller="">on ehci0
    usb4: USB revision 2.0
    uhub4: <intel 1="" 9="" ehci="" root="" hub,="" class="" 0,="" rev="" 2.00="" 1.00,="" addr="">on usb4
    uhub4: 8 ports with 8 removable, self powered
    pcib2: <acpi pci-pci="" bridge="">at device 30.0 on pci0
    pci3: <acpi pci="" bus="">on pcib2
    fxp0: <intel 100="" 82801ba="" (d865)="" pro="" ve="" ethernet="">port 0xbc00-0xbc3f mem 0xfeaff000-0xfeafffff irq 20 at device 8.0 on pci3
    miibus0: <mii bus="">on fxp0
    inphy0: <i82562et 10="" 100="" media="" interface="">PHY 1 on miibus0
    inphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
    fxp0: Ethernet address: 00:13:77:16:42:82
    fxp0: [ITHREAD]
    re0: <d-link dge-528(t)="" gigabit="" ethernet="" adapter="">port 0xb800-0xb8ff mem 0xfeafec00-0xfeafecff irq 21 at device 9.0 on pci3
    re0: Chip rev. 0x10000000
    re0: MAC rev. 0x00000000
    miibus1: <mii bus="">on re0
    rgephy0: <rtl8169s 8110s="" 8211b="" media="" interface="">PHY 1 on miibus1
    rgephy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseT, 1000baseT-FDX, auto
    re0: Ethernet address: 5c:d9:98:53:c0:0c
    re0: [FILTER]
    vr0: <via 10="" vt6105="" rhine="" iii="" 100basetx="">port 0xb400-0xb4ff mem 0xfeafe800-0xfeafe8ff irq 22 at device 10.0 on pci3
    vr0: Quirks: 0x0
    vr0: Revision: 0x8b
    miibus2: <mii bus="">on vr0
    ukphy0: <generic ieee="" 802.3u="" media="" interface="">PHY 1 on miibus2
    ukphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
    vr0: Ethernet address: 1c:bd:b9:e6:08:e7
    vr0: [ITHREAD]
    pci3: <encrypt decrypt,="" network="" computer="" crypto="">at device 12.0 (no driver attached)
    isab0: <pci-isa bridge="">at device 31.0 on pci0
    isa0: <isa bus="">on isab0
    atapci0: <intel ich5="" udma100="" controller="">port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0xfc00-0xfc0f at device 31.1 on pci0
    ata0: <ata 0="" channel="">on atapci0
    ata0: [ITHREAD]
    ata1: <ata 1="" channel="">on atapci0
    ata1: [ITHREAD]
    pci0: <serial bus,="" smbus="">at device 31.3 (no driver attached)
    pci0: <multimedia, audio="">at device 31.5 (no driver attached)
    acpi_button0: <power button="">on acpi0
    speaker0: <pc speaker="">port 0x61 on acpi0
    sio0: configured irq 4 not in bitmap of probed irqs 0
    sio0: port may not be enabled
    sio0: configured irq 4 not in bitmap of probed irqs 0
    sio0: port may not be enabled
    sio0: <16550A-compatible COM port> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
    sio0: type 16550A
    sio0: [FILTER]
    sio1: configured irq 3 not in bitmap of probed irqs 0
    sio1: port may not be enabled
    sio1: configured irq 3 not in bitmap of probed irqs 0
    sio1: port may not be enabled
    sio1: <16550A-compatible COM port> port 0x2f8-0x2ff irq 3 on acpi0
    sio1: type 16550A
    sio1: [FILTER]
    fdc0: <floppy drive="" controller="" (fde)="">port 0x3f0-0x3f5,0x3f7 irq 6 drq 2 on acpi0
    fdc0: [FILTER]
    atkbdc0: <keyboard controller="" (i8042)="">port 0x60,0x64 irq 1 on acpi0
    atkbd0: <at keyboard="">irq 1 on atkbdc0
    kbd0 at atkbd0
    atkbd0: [GIANT-LOCKED]
    atkbd0: [ITHREAD]
    cpu0: <acpi cpu="">on acpi0
    p4tcc0: <cpu frequency="" thermal="" control="">on cpu0
    cpu1: <acpi cpu="">on acpi0
    p4tcc1: <cpu frequency="" thermal="" control="">on cpu1
    pmtimer0 on isa0
    sc0: <system console="">at flags 0x100 on isa0
    sc0: VGA <16 virtual consoles, flags=0x300>
    vga0: <generic isa="" vga="">at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
    Timecounters tick every 1.000 msec
    IPsec: Initialized Security Association Processing.
    ad0: 76319MB <wdc wd800bb-55jkc0="" 05.01c05="">at ata0-master UDMA100
    acd0: CDROM <tsstcorp cd-rom="" ts-h192c="" sc00="">at ata1-master UDMA33
    SMP: AP CPU #1 Launched!

    The other Gigabit NIC gets detected if I remove the one that is currently being detected by which I mean that pfSense only detects one or the other but not both. My friend told me he also experienced the same problem and couldn't find the solution so he was forced to buy an NIC with a different brand and chipset from the ones he has already installed in his setup. I've also tried replacing one of the Gigabit NICs with a generic 10/100 NIC and all were detected without a problem. I only experience said problem if there are two NICs that are identical. Any help would be greatly appreciated. Thanks again and Best Regards.</tsstcorp></wdc></generic></system></cpu></acpi></cpu></acpi></at></keyboard></floppy></pc></power></multimedia,></serial></ata></ata></intel></isa></pci-isa></encrypt></generic></mii></via></rtl8169s></mii></d-link></i82562et></mii></intel></acpi></acpi></intel></intel></intel></intel></intel></intel></intel></intel></intel></intel></intel></intel></intel></intel></intel></vga-compatible></acpi></acpi></intel></acpi></acpi></sec></software></version></sec ></sse3,dtes64,mon,ds_cpl,cnxt-id,xtpr></fpu,vme,de,pse,tsc,msr,pae,mce,cx8,apic,sep,mtrr,pge,mca,cmov,pat,pse36,clflush,dts,acpi,mmx,fxsr,sse,sse2,ss,htt,tm,pbe>



  • The dmesg output shows a device unrecognised by any of the drivers in the system:

    pci3: <encrypt decrypt,="" network="" computer="" crypto="">at device 12.0 (no driver attached)</encrypt>

    I suggest you try a pfSense 2.0 snapshot build because it uses a more up to date version of FreeBSD and consequently the drivers are likely to recognise a wider range of devices. If you are not willing to try "beta" software you will probably need to use an alternate NIC. pfSense 2.0 snapshot builds can be downloaded from http://snapshots.pfsense.org/FreeBSD_RELENG_8_1/i386/pfSense_HEAD/updates/?C=M;O=D


  • Rebel Alliance Global Moderator

    Hmmm, what I can tell you is Im using the same exact nic as both wan and lan and not having any issues.

    pciconf -lv
    re0@pci0:0:9:0: class=0x020000 card=0x311a1385 chip=0x816910ec rev=0x10 hdr=0x00
        class      = network
        subclass  = ethernet
    re1@pci0:0:11:0:        class=0x020000 card=0x311a1385 chip=0x816910ec rev=0x10 hdr=0x00
        class      = network
        subclass  = ethernet


  • Rebel Alliance Developer Netgate

    If only one card shows up in dmesg, that means that the OS itself only probed one card. I would look more at the hardware side of things - BIOS settings for add-on boards, etc. Try different PCI/PCI-e slots, etc. It could even be something specific to that particular NIC model.

    Using identical network cards works fine, I've done it many times, and many motherboards with multiple NICs use the same chip for both and they work fine.

    It's not a general problem, it's something specific to your hardware.


Locked