Locked Out



  • Message to the developers,

    I am using pfsense 2.0 on an alix board.

    I tried to change the default user admin's name from "admin" to something else but I was not allowed to do that. So I disabled the admin account. I then created a new user. I did not know that I had to assign him to a page. When I rebooted I was not able to login anymore because the user I created was not assigned to a page. The admin user was disabled. I had reset to defaults using the serial cable. I tried to edit a .xml config file that was backed up. So that I would be able to log in but I had two lines that said "something…" I got an error message and then I could not even reboot from the minicom session I was connected to through the serial cable. I ended up starting over with another CF card.

    The new features in 2.0 are quite good compared to version 1.2.3. The "widescreen" enhancement did not display my dashboard properly.


  • Rebel Alliance Developer Netgate

    I suppose a check to make sure there is always one enabled admin-level user might help, but in the old tradition:

    Patient: "Doctor, it hurts when I do this!"
    Doctor: "Then don't do that"

    :-)



  • a hint:
    first: create a new user, assign rights.
    second: test that user, if fails, review settings.
    third: if test doesnt fail, disable the old admin


Locked