Clicking "Clear logs" Crashes WebGUI everytime - Unrecoverable!



  • 2.0-RC2 (i386)
    built on Fri Jun 10 21:02:50 EDT 2011

    I was remoted to this system last night and lost connection to the webgui and I could not reconnect. I went to the site where the pfsense box was and thought that I would type #11 to restart webconfigurator. As soon as I did this little dots scrolled across my screen for minutes and the webgui did not recover so I had to reboot the firewall and things are ok.

    Here is what I did right before it crashed:
    1. Went to Status: System logs: Settings
    2. Changed log files to "300" or it could have been "2000"
    3. Click system logs and waiting and nothing happened.
    4. I tried to use multiple machines to connect and nothing. Although they all presented to me a certification message saying press the red x if you still wish to continue, but nothing happened after that, just a spinning circle.



  • Problem Replicated here is exactly what causes the crash:
    1. Went to Status: System logs: System Logs
    Click the clear "logs button"
    This will cause an immediate unrecoverable web gui crash



  • Is this bug being worked on?


  • Banned

    No bug here….. Works fine on the jun 13 snapshot...



  • Ok, Thanks, Great!!



  • I just encountered this issues today. The build was updated this morning 6/18/11 using auto update around 8:45AM EST. (I don't have access to it currently to give details of the exact build).


  • Rebel Alliance Developer Netgate

    I can update and click the button to clear the logs a dozen times or more and I've never had a problem. I can't reproduce it on any VM. I've tried it on i386, amd64, full installs, nanobsd, you name it.

    Enable ssh and check the log after it's been cleared, perhaps there is some error there or something else that might give a clue as to what happened on your specific system.



  • What are the involved hardware plateforms ?
    I also encountered some web GUI freezes issue on my ALIX 2C3 (256 MB SDRAM) and I saw some syslog messages like "php : out of swap"…


  • Rebel Alliance Developer Netgate

    @GLR:

    What are the involved hardware plateforms ?
    I also encountered some web GUI freezes issue on my ALIX 2C3 (256 MB SDRAM) and I saw some syslog messages like "php : out of swap"…

    If you saw that message, your system was out of RAM.



  • Sure… That could explain why the web GUI didn't reply in that case.
    But that's sad if pfSense doesn't work on ALIX anymore.
    May be there is something to tune in this setup to free some RAM...


  • Rebel Alliance Developer Netgate

    It works fine on ALIX, something about your specific configuration may have been using too much RAM.



  • Yes, It seems to work quite fine now (except a lot of bugs in the packages)…

    Btw, if I remember well, the web GUI also freezed on a device having 512 MB of RAM...


  • Rebel Alliance Developer Netgate

    That doesn't mean it was the same problem. This thread is not about the GUI freezing, it's about a specific crash when a specific button is pressed. If you have a different or more general issue, it belongs in another thread.




Locked