[SOLVED] ROOT MOUNT ERROR - When booting up system from RAID



  • I am using the 2.0 RC.

    I am getting the following error:

    
    Trying to mount root from ufs:/dev/da0s1a
    ROOT MOUNT ERROR:
    If you have invalid mount options, reboot, and first try the following from
    the loader prompt:
    
         set vfs.root.mountfrom.options=rw
    
    and then remove invalid mount options from /etc/fstab.
    
    Loader variables:
    vfs.root.mountfrom=ufs:/dev/da0s1a
    vfs.root.mountfrom.options=rw
    
    Manual root filesystem specification:
      <fstype>:<device>Mount <device>using filesystem <fstype>eg. ufs:/dev/da0s1a
                           eg. cd9660:/dev/acd0
                           This is equivalent to: mount -t cd9660 /dev/acd0 /
    
      ?                  List valid disk boot devices
      <empty line="">Abort manual input
    
    mountroot></empty></fstype></device></device></fstype> 
    

    I can bypass this problem by starting the loader [7] in the boot menu and writing the following commands:

    
    load /boot/kernel/rr26xx-8.0.ko
    boot
    
    

    I have copied the raid driver to /boot/kernel/ and to /boot/modules/
    I have added the following command (without the quotes): "rr26xx_load="YES"" in the /boot/defaults/loader.conf as stated in the HighPoint manual, but I am still getting this ROOT MOUNT ERROR.

    It worked with the .iso (copying driver and modifying loader.conf), but not with the hard drive.

    What am I doing wrong? How can I start the system normally without the loader gimmick?

    I get also an error when I shut down/reboot, but that isn't critical ATM.

    All help is welcome.

    EDIT: Corrected the error detail





  • You want that line in /boot/loader.conf.local not the defaults.



  • Corrected the error notification.

    @cmb:

    You want that line in /boot/loader.conf.local not the defaults.

    I had to create that loader.conf.local file and it didn't work.

    @chpalmer:

    http://forum.pfsense.org/index.php/topic,33937.msg176255.html#msg176255

    Might help you…

    I don't think this is the problem, but I could try it.
    It just won't load the raid driver automatically when booting.
    The system works alright after I manually load the driver.


  • Netgate Administrator

    What does it give you in the list of boot devices if you type '?'.

    Steve



  • Solved it.

    I forgot to rename the driver.

    It was named as rr26xx-8.0.ko and it have to be named as rr26xx.ko

    Thanks for everyone.

    Shutdown problem was fixed when I updated to the latest BETA version. RC1 -> 2011-06-15 RC2


Locked