Latest Update - Traffic Shaping Wizard - not working (or is it me :-)



  • Hello all,

    I am running RC2 with the latest update and cant get shaping to work even though I can get traffic into the right queues?

    I have 1 WAN (pppoe - modem in bridge mode) and 1 LAN

    Used the Traffic Shaping Wizard, - 1 LAN &  Multi WAN  option (specified 1 WAN network  on the following screens)

    I have tried HFSC and the easier “Priority” for T/S.

    Situation (using Priority):
    I download (TCP) Fedora 15 on port 563 using a sabnzbd, it is correctly configured to the qlow queue which has a priority of 2.
    I then kick off another download through a browser (tcp)– ubuntu 10.04 on port 80 – this is correctly sent to the default queue with a priority of 4

    Each one will download at 800kb/s by itself, if both are running they both half the bandwidth 400kb/s.  – I want Port 80 traffic to take priority! (and slow down port 563) There are no other settings in the queue settings (realtime,linkshare etc are empty) and bandwidth is also empty. – if I fill in bandwidth 90% default and 10% qlow it has no effect.

    I have read a ton of posts and even if I try HFSC I still cant get it to slow down the 563 traffic. Even though it goes to the right queues?

    Should I re-install and not apply any updates?
    Do I misunderstand v2 traffic shaping?
    Do I need a limiter?

    Any help much appreciated

    Regards

    Nz_Cam



  • bump,

    Am I missing something?

    Does the wizard do all the work? or do i need to add limiters?



  • @nzcam:

    Situation (using Priority):
    I download (TCP) Fedora 15 on port 563 using a sabnzbd, it is correctly configured to the qlow queue which has a priority of 2. I then kick off another download through a browser (tcp)– ubuntu 10.04 on port 80 – this is correctly sent to the default queue with a priority of 4

    Each one will download at 800kb/s by itself, if both are running they both half the bandwidth 400kb/s.  – I want Port 80 traffic to take priority! (and slow down port 563) There are no other settings in the queue settings (realtime,linkshare etc are empty) and bandwidth is also empty. – if I fill in bandwidth 90% default and 10% qlow it has no effect.

    Bandwidth alone does not suffice in shaping decision. Whate are other parameters? Every queue has at least 10 parameters: Bandwidth, Upper-limited m1, d, m2, Real-time m1, d, m2, Link-share m1, d, m2.



  • Hi Dusan,
    thanks for your reply,

    My understanding is that if you are using Priority only (rather than HFSC) then the priority value will be the only deciding factor to have any effect. The result should be that qLow should be completely starved of bandwidth if qdefault has traffic (which has a higher priority)?

    I guess my assumption about priority are wrong?



  • OK,
    I've spent all weekend on this.

    Reinstalled RC2 i386, got all the updates as of 18 June.

    No addons or packages.

    Used wizard for single LAN and Multi WAN (Chose 1 WAN) using HFSC

    Setup queues for penalty box. and so forth.

    reduced total upload and download to half of what it actually is so I could try a get some response from it.

    All traffic is sent to the correct queues but qLow is not limited or slowed in any way when there is traffic in qhigh or q default?

    Surely someone can point me in the right direction as this has taken days and days of screwing around.

    What do i need to do to get qlow to reduce bandwidth whan other traffic is present?


Locked