DNS resolution doesn´t work



  • Hello everybody!

    We use the Pfsense 1.2.3-RC1 (Uptime 253 days) and everything works fine.

    But we have one problem:
    The DNS resolution doesn´t work correctly.

    When I make a "nslookup" from clientA to clientB, the answer is:
    non authorized answer:
    name: clientB.mydomain.com
    adress: our external IP-Address

    Or when I make a "nslookup" from clientA to www.google.com, the answer ist:
    non authorized answer:
    name: www.google.com.mydomain.com
    adress: our external IP-Address

    How you can see, everytime "mydomain.com" is added and our external IP-Address is shown…

    What is going wrong here?

    Sorry for my bad english....


  • Rebel Alliance Developer Netgate

    When testing with DNS tools, always end a fully qualified domain name with a "." - otherwise it will assume you want to append your system's search domain.

    So to lookup "www.google.com" you must use "www.google.com."

    The most common way that you see the behavior you are getting is if "mydomain.com" has wildcard DNS enabled, so it's responding to any query with the same reply.

    Due to the search domain being used, it ends up getting a response for a query that usually fails.

    So your problem could be solved by disabling wildcard DNS on your domain name.



  • @jimp:

    When testing with DNS tools, always end a fully qualified domain name with a "." - otherwise it will assume you want to append your system's search domain.

    So to lookup "www.google.com" you must use "www.google.com."

    The most common way that you see the behavior you are getting is if "mydomain.com" has wildcard DNS enabled, so it's responding to any query with the same reply.

    Due to the search domain being used, it ends up getting a response for a query that usually fails.

    So your problem could be solved by disabling wildcard DNS on your domain name.

    try without www, don't use it at all.


Log in to reply