OLSSR not turning off



  • The enable checkbox does not turn the olsr service off when unchecked.  I had turned it on to do some testing with my wireless network.  Once it was on I couldn't turn it off.. the OLSR packets just kept on going.  I had to reboot.



  • I put a fix for this.
    Thank you for reporting.



  • Thank you for the previous fix.

    I have a new problem now with OLSR and it overriding routes on my router.  I'm running 2.0 RC 1 and 2 (going to update the router to RC3 shortly.)

    I have a router with 3 interfaces with OLSR enabled, each is connected to a separate Wireless network (2.4Ghz, 900Mhz, and a 5.8Ghz)  via ethernet.

    Interface 1:  101.94.43.254/24  connected via ethernet cable to a Robin Mesh radio at 101.94.43.1 which is on a mesh of approx 20 nodes.
    Interface 2:  10.1.0.4/24 connected to a UBNT 900Mhz bridge at 10.1.0.3 using WDS as a backbone, connected to other radios and pfsense firewalls.
    Interface 3:  10.2.0.4/24 connected to a UBNT 5.8Ghz Bridge at 10.2.0.3 being used for a point to point link to the other side of the mesh to add some speed and capacity with another pfsense firewall at 10.2.0.1

    what i'm finding is that the olsrd routes seem to be over riding even the most lowest metric routes, i.e. a route to 101.94.43.1 which is directly connected to the router on interface 1, is being listed in the routing table to use 10.2.0.1 as the gateway…

    Is there a way to add a default cost to all OLSR routes? or will the olsrd interface Weight parameter be able to help with this?


Log in to reply