NTop password not working on latest RC



  • I have just installed nTop on the latest RC of pfSense 2 and it is asking me for a username/password for certain pages.  When I type in "admin" and the password I set in nTop Settings, it does not work - it asks me for my password again.  What must I do?



  • Same here. I tried with username 'admin' and password 'admin' and that worked. Couldn't even change the password through the web interface or the command line (ntop -u root -A returns without prompting).

    pfSense 2.0-RC3


  • Rebel Alliance Developer Netgate

    I tried this the other day and had an issue as well. It would appear that ntop's own command didn't work when run from the command line:

    ntop --set-admin-password=blah
    

    I tried that when ntop was running and when it was stopped.

    It needs some more investigation, could be a permissions issue or something else about the command changed.


  • Rebel Alliance Developer Netgate

    I just committed some fixed for ntop, I found the problem.

    You can't change the password while ntop is running. I restructured the code a bit so now it tries to stop ntop, wait 20 seconds for it to shutdown cleanly, then it changes the password and restarts ntop.

    I also fixed up a few other areas in the code that were iffy/not working/not proper.



  • Yeah I did stop ntop, and ran this yesterday:

    
    [2.0-RC2][admin@fw.home]/root(8): /usr/local/bin/ntop --set-admin-password=admin
    Sun Jun 19 09:41:51 2011  NOTE: Interface merge enabled by default
    Sun Jun 19 09:41:51 2011  Initializing gdbm databases
    Sun Jun 19 09:41:51 2011  Setting administrator password...
    Sun Jun 19 09:41:51 2011  Admin password set...
    
    

    But it did not make any difference.


  • Rebel Alliance Developer Netgate

    You also have to remove the password database for ntop before setting it (forgot to mention that, it's already in the code)



  • @jimp:

    You also have to remove the password database for ntop before setting it (forgot to mention that, it's already in the code)

    Your fix did it - thanks.  Just curious, the original reason I wanted this to work is to see the Hosts Map.  It asks me for a new Google API key to be created.  What URL do I use?  I access nTop via http://192.168.0.10:3000/ - so should I use that?  If I do it still tells me the host key is wrong.  If you are the wrong person to ask just tell me and I'll ask on the nTop forums.


  • Rebel Alliance Developer Netgate

    I'm not sure about that. I don't recall what it wants in there, though I thought it wanted a hostname, not an IP address.


Locked